View Issue Details

IDProjectCategoryView StatusLast Update
0003849unrealircdpublic2009-12-22 14:55
ReporternephilimAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003849: Log function for kline does not work.
DescriptionIn the latest stable versions, the entry in the logblock for logging kline actions produces nothing in the logfiles. I don't know how long this is has been a problem, since I've only noticed it today.

A friend of mine, who is running 3.2.7, also has this problem.
Steps To ReproduceAdd this block to the config:

log "kline.log" {
        maxsize 2097152;
        flags {
                kline;
        };
};
TagsNo tags attached.
3rd party modules

Activities

Stealth

2009-07-23 17:39

reporter   ~0015885

Changed summary from "Log function for kline/gline does not work."

There are 2 different log flags, one for klines and one for other TLK actions (spamfilters, glines, etc).

Stealth

2009-07-23 17:42

reporter   ~0015886

It appears as though the kline flag doesn't need to log anything... klines are logged with the TKL flag.

nephilim

2009-07-23 18:56

reporter   ~0015891

That was indeed the flag that we were looking for. Though it was not in the documentation at the time..

What does the kline flag do then?

Stealth

2009-07-23 18:58

reporter   ~0015892

At the current time the kline flag does nothing at all. My best guess is it has been left for any modules which may use the kline flag for their own logging.

nephilim

2009-07-23 19:07

reporter   ~0015893

ow alright. In that case, the 'bug' seems to be solved in the meaning of that we were using the wrong flag.

Thanks!

syzop

2009-12-22 14:54

administrator   ~0015981

.781:
- Removed log target 'kline' from documentation, as it didn't do anything
  (use 'tkl' instead). Reported by nephilim and Stealth (0003849).

Issue History

Date Modified Username Field Change
2009-05-23 17:12 nephilim New Issue
2009-07-23 17:39 Stealth QA => Not touched yet by developer
2009-07-23 17:39 Stealth U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-07-23 17:39 Stealth U4: Upstream notification of bug => Not decided
2009-07-23 17:39 Stealth U4: Contributor working on this => None
2009-07-23 17:39 Stealth Note Added: 0015885
2009-07-23 17:39 Stealth Summary Log function for kline/gline does not work. => Log function for kline does not work.
2009-07-23 17:40 Stealth Status new => confirmed
2009-07-23 17:42 Stealth Note Added: 0015886
2009-07-23 18:56 nephilim Note Added: 0015891
2009-07-23 18:58 Stealth Note Added: 0015892
2009-07-23 19:07 nephilim Note Added: 0015893
2009-12-22 14:54 syzop Note Added: 0015981
2009-12-22 14:54 syzop Status confirmed => resolved
2009-12-22 14:54 syzop Fixed in Version => 3.2.9-RC1
2009-12-22 14:54 syzop Resolution open => fixed
2009-12-22 14:54 syzop Assigned To => syzop