View Issue Details

IDProjectCategoryView StatusLast Update
0003853unrealircdpublic2009-06-08 04:50
ReporteraragonAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformunixOSDebianOS Version
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003853: Negative timestamp offset at startup breaks autoconnect
DescriptionIf unreal detects a negative timestamp offset at startup (eg. via timesynch), it will not execute autoconnect link blocks until the next rehash is received.
Steps To Reproduce1. Set system clock into the future.
2. Start unreal with at least one autoconnect link block in config.
Additional InformationDisabling timesynch and removing ircd.tune before startup is a possible workaround.
TagsNo tags attached.
3rd party modules

Activities

syzop

2009-06-08 04:50

administrator   ~0015867

Fixed in .768, thanks for the report.

- Fixed issue where a negative time offset (either caused by ircd.tune or
  timesynch) made autoconnect not work for the duration of the offset
  (eg: -60 would make autoconnect wait 60 seconds after boot, instead of
  autoconnecting almost immediately). Reported by aragon (0003853).

Issue History

Date Modified Username Field Change
2009-06-06 21:43 aragon New Issue
2009-06-08 04:50 syzop QA => Not touched yet by developer
2009-06-08 04:50 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-06-08 04:50 syzop Note Added: 0015867
2009-06-08 04:50 syzop Status new => resolved
2009-06-08 04:50 syzop Fixed in Version => 3.2.9-RC1
2009-06-08 04:50 syzop Resolution open => fixed
2009-06-08 04:50 syzop Assigned To => syzop