View Issue Details

IDProjectCategoryView StatusLast Update
0003874unrealircdpublic2015-07-29 17:52
ReporterccowartAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSFreeBSDOS Version7.1
Product Version3.2.8 
Target VersionFixed in Version3.2.10.2 
Summary0003874: ipv6 nameserver support
DescriptionI typically have a single resolver as an IPv6 address listed in /etc/resolv.conf. After noticing that unrealircd was failing to resolve the reverse DNS for client connections, I preceded my IPv6 address with the IPv4 address configured to the same interface on the DNS server. Everything began working.

If unreal actually supports IPv6, it shouldn't need IPv4 for DNS lookups.

From /quote version:
13:56 -!- Unreal3.2.8.1. irc.timesinks.net Fhi6XeOoE [FreeBSD
          jayne.timesinks.net 7.1-RELEASE-p8 FreeBSD 7.1-RELEASE-p8 #0: Fri Oct
          2 07:10:41 UTC 2009
          root@i386-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC
          i386=2309]
13:56 !irc.timesinks.net OpenSSL 0.9.8e 23 Feb 2007
13:56 -!- UHNAMES NAMESX SAFELIST HCN MAXCHANNELS=20 CHANLIMIT=#:20
          MAXLIST=b:60,e:60,I:60 NICKLEN=30 CHANNELLEN=32 TOPICLEN=307
          KICKLEN=307 AWAYLEN=307 MAXTARGETS=20 are supported by this server
13:56 -!- WALLCHOPS WATCH=128 WATCHOPTS=A SILENCE=15 MODES=12 CHANTYPES=#
          PREFIX=(ohv)@%+ CHANMODES=beIqa,kfL,lj,psmntirRcOAQKVCuzNSMTG
          NETWORK=Timesinks CASEMAPPING=ascii EXTBAN=~,cqnr ELIST=MNUCT
          STATUSMSG=@%+ are supported by this server
13:56 -!- EXCEPTS INVEX CMDS=KNOCK,MAP,DCCALLOW,USERIP are supported by this
          server
TagsNo tags attached.
3rd party modules

Activities

syzop

2009-11-07 13:29

administrator   ~0015951

Last edited: 2009-11-07 13:30

We use the c-ares library ( http://c-ares.haxx.se/ ).
Once they support IPv6, we will too, once we upgrade to that version (& implement any changes if required).
I'm not entirely up to date with regards to c-ares development, so I don't know if they support it now (it has always been on their todo/roadmap, though).

ohnobinki

2013-01-27 06:37

reporter   ~0017389

I hope this has fixed itself by now? I’m pretty sure that ares does the right thing when reading entries from /etc/resolv.conf nowadays...

A separate issue is that the mechanism our set::dns::nameserver uses (only use when /etc/resolv.conf has no nameserver lines) to communicate with the c-ares library does not allow the user to specify an IPv6 server (see http://c-ares.haxx.se/ares_init.html ARES_OPT_SERVERS and http://hg.unrealircd.org/hg/unreal/file/f07e2f42a977/src/res.c#l169 ).

Jobe1986

2013-01-28 09:08

reporter   ~0017391

As of c-ares 1.7.1, c-ares includes a ares_set_servers() function that is inteded to replace the ARES_OPT_SERVERS option to allow IPv4 AND IPv6 name servers to be specified: http://man.cx/ares_set_servers(3)

syzop

2015-07-09 19:14

administrator   ~0018441

This was probably fixed a few years ago. We don't set any nameservers in UnrealIRCd and leave this 100% up to c-ares. Since c-ares added the IPv6 functionality years ago we should be good :)

syzop

2015-07-29 17:52

administrator   ~0018572

Just to confirm, yes this works OK in 3.4-beta3. Tried with a single ::1 nameserver.

Issue History

Date Modified Username Field Change
2009-11-06 23:08 ccowart New Issue
2009-11-07 13:29 syzop Note Added: 0015951
2009-11-07 13:30 syzop QA => Not touched yet by developer
2009-11-07 13:30 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-11-07 13:30 syzop U4: Upstream notification of bug => Not decided
2009-11-07 13:30 syzop U4: Contributor working on this => None
2009-11-07 13:30 syzop Severity minor => feature
2009-11-07 13:30 syzop Status new => acknowledged
2009-11-07 13:30 syzop Summary dns lookup failures using ipv6 transport => ipv6 nameserver support
2009-11-07 13:30 syzop Note Edited: 0015951
2013-01-27 06:37 ohnobinki Note Added: 0017389
2013-01-27 06:37 ohnobinki Status acknowledged => feedback
2013-01-28 09:08 Jobe1986 Note Added: 0017391
2013-02-12 07:00 dummy Status feedback => has patch
2013-02-19 22:55 syzop Status has patch => confirmed
2015-07-09 19:14 syzop Note Added: 0018441
2015-07-09 19:14 syzop Status confirmed => resolved
2015-07-09 19:14 syzop Fixed in Version => 3.2.10.2
2015-07-09 19:14 syzop Resolution open => fixed
2015-07-09 19:14 syzop Assigned To => syzop
2015-07-29 17:52 syzop Note Added: 0018572