View Issue Details

IDProjectCategoryView StatusLast Update
0003882unrealircdpublic2010-01-04 14:23
ReporterMouseAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentosOS Version4.5
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003882: /restart do not start ircd if syslogd is not running on linux box.
Descriptionwhy restart have to depend on syslogd.
I did read thru ircd codes and I see that it seem depend on syslogd.

[root@localhost log]#
[root@localhost log]#
[root@localhost log]#
[root@localhost log]# killall syslogd
[root@localhost log]#
[root@localhost log]#
[root@localhost log]#


[19:48:58] -hub.ufo.net- *** Notice -- Server is Restarting by request of stupidircd
-
[19:48:58] -hub.ufo.net- Server Restarting. stupidircd
-
[19:48:58] -hub.ufo.net- *** Notice -- Aieeeee!!! Restarting server... No reason
-
[19:48:58] * Disconnected
-
[19:49:03] * Connecting to 192.168.1.103 (6667)
-
[19:49:04] * Unable to connect to server (Connection refused)
Steps To Reproducekillall syslogd or disable syslogd and killall ircd or
./unreal stop
./unreal start
restart your ircd via ssh or console.

go on ircd and operup then do /restart <yourpass>


TagsNo tags attached.
3rd party modules

Activities

2010-01-04 14:15

 

fd.fix.patch (1,396 bytes)

syzop

2010-01-04 14:17

administrator   ~0015994

This should now be fixed in CVS .789. I've also attached the patch to this bug report.

Changelog:
- Fixed a /RESTART issue on Linux: Unreal did not properly close all file-
  descriptors. Because of this, Unreal did not restart properly as you would
  get an "Address already in use" error. This only seemed to happen when
  logging to syslog. Reported by Mouse (0003882).
- Fixed a similar issue with syslog (and debugmode) and closing fd's as well:
  the first port we listened on would not open up, ircd did not log any error.

syzop

2010-01-04 14:23

administrator   ~0015995

Last edited: 2010-01-04 14:23

I've slightly changed the changelog to:
..
  get an "Address already in use" error. This only seemed to happen when
  logging to syslog, or when there was something wrong with syslogd.
..
as it wasn't exactly clear when this happened (like.. I didn't have to kill syslogd in order to reproduce it, but had to enable syslog logging in unrealircd.conf).. anyway, it sounds like this only happened sporadically...

Issue History

Date Modified Username Field Change
2009-12-22 02:57 Mouse New Issue
2010-01-04 14:15 syzop File Added: fd.fix.patch
2010-01-04 14:17 syzop QA => Not touched yet by developer
2010-01-04 14:17 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-01-04 14:17 syzop Note Added: 0015994
2010-01-04 14:17 syzop Status new => resolved
2010-01-04 14:17 syzop Fixed in Version => 3.2.9-RC1
2010-01-04 14:17 syzop Resolution open => fixed
2010-01-04 14:17 syzop Assigned To => syzop
2010-01-04 14:23 syzop Note Added: 0015995
2010-01-04 14:23 syzop Note Edited: 0015995