View Issue Details

IDProjectCategoryView StatusLast Update
0003889unrealinstallingpublic2010-02-13 12:22
ReporterohnobinkiAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformamd64OSGentooOS Version2.0
Product Version3.2.9-RC1 
Target VersionFixed in Version3.2.9-RC1 
Summary0003889: old pkg-config m4 macros
Descriptionaclocal.m4 has an old version of the pkg-config macros included in it. See the following diff between pkg-config-0.23 and what you have (attached). The _PKG_CONFIG part of the diff is really important for when the OS unrealircd is being installed onto does not have pkg-config installed and the user wants to pass CARES_LIBS and CARES_CFLAGS to ./configure (like pkg-config says you may). Passing these variables doesn't work with the macros in aclocal.m4

TagsNo tags attached.
3rd party modules

Activities

2010-01-25 20:16

 

old-pkg.m4.patch (1,397 bytes)

syzop

2010-02-13 12:22

administrator   ~0016018

- Updated pkg-config m4 macro (now 0.23) for configure, patch from ohnobinki
  (0003889).

Issue History

Date Modified Username Field Change
2010-01-25 20:16 ohnobinki New Issue
2010-01-25 20:16 ohnobinki File Added: old-pkg.m4.patch
2010-02-13 12:22 syzop QA => Not touched yet by developer
2010-02-13 12:22 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-02-13 12:22 syzop Note Added: 0016018
2010-02-13 12:22 syzop Status new => resolved
2010-02-13 12:22 syzop Fixed in Version => 3.2.9-RC1
2010-02-13 12:22 syzop Resolution open => fixed
2010-02-13 12:22 syzop Assigned To => syzop