View Issue Details

IDProjectCategoryView StatusLast Update
0003891unrealinstallingpublic2010-05-06 00:41
ReporterohnobinkiAssigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformamd64OSGentooOS Version2.0
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003891: compile as hub or compile as leaf is pointless
Descriptionohnobinki@ohnopublishing ~/Unreal3.2 $ find -regex '.*\.[ch]' | xargs grep HUB
./src/s_debug.c:#ifdef HUB

This only adds 'h' to the serverflags string which only appears useful to the ``link deny'' block of other servers. IMO, this --enable-hub flag should be purged and 'h' should just show up in the serverflags string (for sake of backwards-compatibility). People shouldn't be using this flag in their deny link blocks, however, because this flag doesn't really mean anything (so far as I can divine ;-) ).

See attached patch for my understanding of how this would be addressed. The changes seem _too_ superficial, maybe I missed something?
TagsNo tags attached.
3rd party modules

Activities

2010-02-19 19:21

 

unrealircd-3.2.9_pre-hub-nocompiletime.patch (3,333 bytes)

ohnobinki

2010-05-06 00:41

reporter   ~0016080

- Remove the ``Compile as hub/leaf'' concept as I'm quite sure this doesn't
  actually do anything (0003891)

Issue History

Date Modified Username Field Change
2010-02-19 19:21 ohnobinki New Issue
2010-02-19 19:21 ohnobinki File Added: unrealircd-3.2.9_pre-hub-nocompiletime.patch
2010-05-06 00:41 ohnobinki QA => Fixed by developer, needs QA testing
2010-05-06 00:41 ohnobinki U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-05-06 00:41 ohnobinki U4: Upstream notification of bug => Not decided
2010-05-06 00:41 ohnobinki U4: Contributor working on this => None
2010-05-06 00:41 ohnobinki Note Added: 0016080
2010-05-06 00:41 ohnobinki Assigned To => ohnobinki
2010-05-06 00:41 ohnobinki Status new => resolved
2010-05-06 00:41 ohnobinki Resolution open => fixed
2010-05-06 00:41 ohnobinki Fixed in Version => 3.2.9-RC1
2010-05-06 00:41 ohnobinki Description Updated