View Issue Details

IDProjectCategoryView StatusLast Update
0003894unrealircdpublic2010-03-03 14:56
ReporterbitmasterAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version8.04 LTS
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003894: REHASH -MOTD not rehashing all MOTDs
Description/REHASH -MOTD should rehash all MOTD files, according to the output:
*** Notice -- Rehashing all MOTDs and RULES on request of <nick>

But, the OPERMOTD and BOTMOTD appear to be not included. Those only rehash
using /REHASH, or /REHASH -OPERMOTD and /REHASH -BOTMOTD separately.

My suggestion is to include OPERMOTD and BOTMOTD to rehash when
using /REHASH -MOTD, especially since the tld{} config block is also
being rehashed and OPERMOTD or BOTMOTD files may be specified there.
Steps To Reproduce/REHASH -MOTD
TagsNo tags attached.
3rd party modules

Activities

syzop

2010-03-03 14:56

administrator   ~0016046

Fixed in .802:
- Made '/REHASH -motd' really rehash *all* MOTD, OPERMOTD, BOTMOTD and RULES
  files. Reported by bitmaster (0003894).

Issue History

Date Modified Username Field Change
2010-03-03 12:14 bitmaster New Issue
2010-03-03 14:56 syzop QA => Not touched yet by developer
2010-03-03 14:56 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-03-03 14:56 syzop Note Added: 0016046
2010-03-03 14:56 syzop Status new => resolved
2010-03-03 14:56 syzop Fixed in Version => 3.2.9-RC1
2010-03-03 14:56 syzop Resolution open => fixed
2010-03-03 14:56 syzop Assigned To => syzop