View Issue Details

IDProjectCategoryView StatusLast Update
0003901unrealircdpublic2010-04-25 21:16
ReporterohnobinkiAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformubuntu/gentooOSlinuxOS Versionuhm...
Product Version3.2.9-RC1 
Target VersionFixed in Version3.2.9-RC1 
Summary0003901: CVS/3.2.9 cannot link/connect to a <=3.2.8.1 hub
Description3.2.9_pre will connect and send PASS and PROTOCTL commands but not send the SERVER command. 3.2.9_pre expects some response from the hub before it's willing to send the SERVER command. 3.2.8 will wait until the SERVER command is sent before continuing the linking process.

I believe that the following scenario should work: 3.2.9_pre as a hub and 3.2.8.1 as a leaf. Also, if the hub is making outbound connections to 3.2.9_pre servers, it should work. I haven't tried testing this, though, due to lack of time.
Steps To Reproduce- Set up 3.2.8.1 as a hub
- put a link block for that server in a 3.2.9_pre's config
- issue the CONNECT command on the 3.2.9_pre server
TagsNo tags attached.
3rd party modules

Activities

syzop

2010-04-25 21:15

administrator   ~0016078

I somehow completely forgot that case, it is now solved with a silly and ugly workaround in .803:
- Fix stupid issue where current CVS would no longer link TO an earlier
  Unreal server (eg: outgoing connect to a 3.2.8 hub). Reported by ohnobinki
  (0003901).

Issue History

Date Modified Username Field Change
2010-04-17 17:41 ohnobinki New Issue
2010-04-17 19:16 syzop Status new => acknowledged
2010-04-25 21:15 syzop QA => Not touched yet by developer
2010-04-25 21:15 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-04-25 21:15 syzop Note Added: 0016078
2010-04-25 21:15 syzop Status acknowledged => resolved
2010-04-25 21:15 syzop Fixed in Version => 3.2.9-RC1
2010-04-25 21:15 syzop Resolution open => fixed
2010-04-25 21:15 syzop Assigned To => syzop