View Issue Details

IDProjectCategoryView StatusLast Update
0003909unrealircdpublic2010-05-24 14:01
ReportertabrisnetAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux/x86OSDebian LinuxOS Versiontesting
Product Version3.2.9-RC1 
Target VersionFixed in Version3.2.9-RC1 
Summary0003909: ban except (+e) broken in CVS
DescriptionIf you have _any_ +e set (even completely irrelevant like reallylongnick!outis@*ignorethis), +b will not match on a WEBIRC user.
Steps To Reproduceset an irrelevant or otherwise non-matching +e, and then set a +b on a user. Watch them join over and over again.
TagsNo tags attached.
3rd party modules

Activities

syzop

2010-05-24 13:47

administrator   ~0016103

Last edited: 2010-05-24 13:48

Bug seems to be in CVS only (so 3.2.8.1 unaffected). The cause is most likely the backport of the "stacked/chained extbans" feature (from 3.3*).

syzop

2010-05-24 14:01

administrator   ~0016104

Fixed in CVS .813, thanks for the report :)
- Fixed bug in CVS where the ban exempt (+e) handling was reversed: if a
  non-matching +e was present, one could walk through bans. Reported by
  tabrisnet (0003909). Bug was caused by chained/stacked extbans.

Issue History

Date Modified Username Field Change
2010-05-24 06:59 tabrisnet New Issue
2010-05-24 13:38 syzop Status new => confirmed
2010-05-24 13:46 syzop QA => Not touched yet by developer
2010-05-24 13:46 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-05-24 13:46 syzop U4: Upstream notification of bug => Not decided
2010-05-24 13:46 syzop U4: Contributor working on this => None
2010-05-24 13:46 syzop Product Version 3.2.8 => 3.2.9-RC1
2010-05-24 13:47 syzop Note Added: 0016103
2010-05-24 13:48 syzop Note Edited: 0016103
2010-05-24 13:56 syzop Summary ban-except broken re WEBIRC => ban except (+e) broken in CVS
2010-05-24 14:01 syzop Note Added: 0016104
2010-05-24 14:01 syzop Status confirmed => resolved
2010-05-24 14:01 syzop Fixed in Version => 3.2.9-RC1
2010-05-24 14:01 syzop Resolution open => fixed
2010-05-24 14:01 syzop Assigned To => syzop