View Issue Details

IDProjectCategoryView StatusLast Update
0003925unrealinstallingpublic2010-11-17 18:09
Reporterwarg Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
OSLinux & BSD 
Product Version3.2.8 
Summary0003925: curlinstall broken
Descriptionwhen using curlinstall script, curl.h is non existent in $HOME/curl/include, and this causes unreal's compile to fail. This is probably on the curl vendor end, but a simple fix is doable - patch attached.
Steps To Reproduceusing c-ares-1.7.3
using curl-7.21.0

run the ./curlinstall as documented, then try to compile unreal.

ircd.c:75:23: error: curl/curl.h: No such file or directory
Additional Informationhttp://forums.unrealircd.com/viewtopic.php?f=3&t=6608&start=0
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0003656 resolvedsyzop Include curl for automatic detection and configuration with Unreal 
related to 0003931 resolvedohnobinki ircd no longer compiles with curl 
related to 0003920 closed http://forums.unrealircd.com/viewtopic.php?f=3&t=353 

Activities

2010-07-12 21:36

 

curlinstall.patch (298 bytes)

warg

2010-07-12 22:59

reporter   ~0016146

NOTICE: my patch didn't correct this issue, working on other options.

syzop

2010-07-13 17:45

administrator   ~0016147

Huh? How can they forget to install curl.h? That sounds rather silly...
You sure? :P

Sorry no time to test atm.

syzop

2010-07-15 13:04

administrator   ~0016196

Last edited: 2010-07-15 13:05

I've tried installing with the auto-installer (so answering Yes to the automatic install question) with latest CVS, though I had to fix this bug first before I could:
- The patch from 0003888 made ./Config favor the curl in /usr, even if it
  was not compiled with c-ares, which is clearly a bad idea as then the
  entire IRCd can hang for several seconds or more...
  We now check if they support asynch DNS, and skip them if they don't.

AND... this bug 0003931 needs to be fixed, I ripped out the check locally but it's not in CVS because maybe binki can fix it without removing the check altogether -- like by moving the check to the end.

Anyway, then it compiles fine.

When I was at it, I also updated our curl-latest.tar.gz to the latest version (7.21.0 - same as you), and that too compiles fine.

Yay :)

Anyway, you better wait till 0003931 is fixed before checking if it works for you too.

warg

2010-07-20 04:57

reporter   ~0016224

@0016147 yeah it is silly, but on my end it's what happened, and iirc i showed binki in a screen session. i'm really out of swing on the bug posting, having been away for atleast a couple years, so my apologies for leaving information out and such. i'll get back to you on this soon.

syzop

2010-07-20 12:02

administrator   ~0016226

No need for apologies ;)
Maybe you could check with latest CVS, now the last bugfix was checked in. Perhaps even rename the curl to curl.old before you try it, so you can also test our new auto-install thingy.

Also, since I don't know if you meant it literally: curl.h is never in ~/curl/include itself, but rather in ~/curl/include/curl/curl.h (as to make #include <curl/curl.h> work, just like with openssl, etc).

syzop

2010-11-17 18:09

administrator   ~0016424

I'm assuming this has been fixed, as I couldn't reproduce it after the final changes were made to the script.

If not, please re-open (or repost). Thanks.

Issue History

Date Modified Username Field Change
2010-07-12 21:36 warg New Issue
2010-07-12 21:36 warg File Added: curlinstall.patch
2010-07-12 22:59 warg Note Added: 0016146
2010-07-13 02:21 ohnobinki Relationship added duplicate of 0003656
2010-07-13 17:45 syzop Note Added: 0016147
2010-07-15 13:04 syzop Note Added: 0016196
2010-07-15 13:05 syzop Note Edited: 0016196
2010-07-16 02:17 ohnobinki Relationship added related to 0003931
2010-07-20 04:57 warg Note Added: 0016224
2010-07-20 12:02 syzop Note Added: 0016226
2010-08-26 04:41 ohnobinki Relationship added related to 0003920
2010-11-17 18:09 syzop Note Added: 0016424
2010-11-17 18:09 syzop Status new => closed
2010-11-17 18:09 syzop Resolution open => no change required