View Issue Details

IDProjectCategoryView StatusLast Update
0003946unrealircdpublic2013-05-20 21:26
ReportertabrisnetAssigned Tonenolod 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.8 
Target VersionFixed in Version3.4-alpha1 
Summary0003946: CS INVITE noisy due to ircd invite notice
DescriptionImplemented a CS JOIN that calls CS INVITE (if user has access), so that a JOIN may always succeed (regardless of +i, +k, +b, etc). Unfortunately every time a user with access uses CS JOIN (NS AJOIN uses CS JOIN), an invite notice is sent to the channel. For some channels, this is considered annoying.

Can we add a SVSINVITE that doesn't do this, or make a configurable option to disable the notice?
TagsNo tags attached.
3rd party modules

Activities

ohnobinki

2010-08-23 05:11

reporter   ~0016300

I think that this has come up before, with the correct solution being use of some invite numeric instead of an invite notice.

2010-08-23 07:11

 

unreal-3946-no-invite-channotice.patch (1,506 bytes)

ohnobinki

2010-08-23 07:11

reporter   ~0016301

unreal-3946-no-invite-channotice.patch: I think that this is the correct way to inform channel members (ops only) of channel invites.

syzop

2010-11-15 18:15

administrator   ~0016417

How do other ircds deal with this. Do they use the method proposed in the patch?

ohnobinki

2010-12-16 02:28

reporter  

unreal-3946-no-invite-channotice-numeric-345.patch (3,638 bytes)

ohnobinki

2010-12-16 03:14

reporter   ~0016464

unreal-3946-no-invite-channotice-numeric-345.patch: Use a numeric reply which I found in a random IRC protocol listing online.

I can't find it used by anyone in my short search (of just freenode), but using this numeric would kill the NOTICEs and still allow people access to the information if they want it.

syzop

2010-12-16 21:07

administrator   ~0016465

I could be wrong, and.. it could just be 'coincidence', but AFAICT numerics only get sent in reply to some command [hence RPL_xxx and errors ERR_xxxx]... not 'out of the blue'?
I don't know if it's a 'rule' though. And if it's still true.

katsklaw

2010-12-17 02:50

reporter   ~0016466

Last edited: 2010-12-17 03:24

View 5 revisions

notice vs numeric. numerics IMHO are far easier to parse for scripts (namely mIRC). However, I've found that basic, not so technical users like notices because they usually go to the active window and users have the ability to ignore or "forget" some important information also appears in status. I've encountered this very problem shortly after coding a custom module for a network that used sendto_umode() (server notice). I've already been asked to re-write it as a NOTICE instead because users fail to see the announcements in their status window.

In short, keep the ircd invite notice as-is or create a method for admins to choose which method they wish to use.

nenolod

2013-05-20 21:26

reporter   ~0017642

The new cap_invitenotify.so module based on InspIRCd's proposal fixes this bug entirely.

We will remove the old notice in a later revision.

Issue History

Date Modified Username Field Change
2010-08-22 21:15 tabrisnet New Issue
2010-08-23 05:11 ohnobinki Note Added: 0016300
2010-08-23 07:11 ohnobinki File Added: unreal-3946-no-invite-channotice.patch
2010-08-23 07:11 ohnobinki Note Added: 0016301
2010-08-23 07:12 ohnobinki Status new => confirmed
2010-11-15 18:15 syzop Note Added: 0016417
2010-11-15 18:15 syzop Status confirmed => has patch
2010-12-16 02:28 ohnobinki File Added: unreal-3946-no-invite-channotice-numeric-345.patch
2010-12-16 03:14 ohnobinki Note Added: 0016464
2010-12-16 21:07 syzop Note Added: 0016465
2010-12-17 02:50 katsklaw Note Added: 0016466
2010-12-17 02:53 katsklaw Note Edited: 0016466 View Revisions
2010-12-17 02:54 katsklaw Note Edited: 0016466 View Revisions
2010-12-17 03:20 katsklaw Note Edited: 0016466 View Revisions
2010-12-17 03:24 katsklaw Note Edited: 0016466 View Revisions
2013-05-20 21:26 nenolod Note Added: 0017642
2013-05-20 21:26 nenolod Status has patch => resolved
2013-05-20 21:26 nenolod Resolution open => fixed
2013-05-20 21:26 nenolod Assigned To => nenolod
2013-05-20 21:26 nenolod Fixed in Version => 3.4-alpha1