View Issue Details

IDProjectCategoryView StatusLast Update
0003959unrealdocumentationpublic2010-09-15 18:15
ReporterCoreDuoAssigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003959: badword message {} does not apply to channel messages, docs are unclear 'bout this
DescriptionWord filters using channel mode +G work as advertised with badword all {}. However, it does not work with user mode +G. I also tested with badword message {} and badword channel {}. badword channel {} works, badword message {} does not.

TagsNo tags attached.
3rd party modules

Activities

syzop

2010-09-15 10:03

administrator   ~0016357

badword message { } (and badword all) does work here.

However, the description in help.conf (and maybe unr32docs?) is incorrect. It filters incoming messages when you set yourself +G, not outgoing.

CoreDuo

2010-09-15 13:36

reporter   ~0016358

It filtered nothing when i tested it. What am I missing?

syzop

2010-09-15 15:07

administrator   ~0016359

Last edited: 2010-09-15 15:09

I don't know? It really works perfectly fine here :)
Two clients, A and B. B is set +G, A says fuck, B receives the message as <censored>.

Btw, I've tested it with the CVS version. But there haven't been any changes in that code since 3.2.8 AFAICT... so that shouldn't matter.

syzop

2010-09-15 15:13

administrator   ~0016360

You are private messaging, aren't you? :P

CoreDuo

2010-09-15 15:50

reporter   ~0016361

Last edited: 2010-09-15 15:53

No, I wasn't private messaging. It was in a public channel without the channel mode +G but usermode +G instead.

Is this not the intended usage? If not, maybe the documentation should state that.

ohnobinki

2010-09-15 18:12

reporter   ~0016362

Well, intended usage is obviously so that one can prevent peopel from PMing badwords to eachother. You can use set::modes-on-connect and set::restrict-usermodes to prevent people from PMing badwords. You can do a similar thing per-channel as well with set::restrict-channelmodes and set::modes-on-join .

Your use case, where you want to prevent certain people from using badwords in a given channel does not fit into the existing paradigm. For example, user A might see user B in some channel use a badword. User A would assume that he can use the same badword in this channel that user B used. Having it so that some ``priviliged'' users are excluded from badwords in a specific channel just doesn't make any sense to me at all. However, if you want this, I think this bug should be changed into a feature request for such behavior.

I've made an attempt to better document the existing behavior:
- Document the badword block more explicitly and clearly. (0003959)

ohnobinki

2010-09-15 18:14

reporter   ~0016363

I think that the documentation half of this bug is complete. If you want to file a feature request to only apply the badwords filter to certain users in a channel, please file a new bug.

Issue History

Date Modified Username Field Change
2010-09-15 05:27 CoreDuo New Issue
2010-09-15 10:03 syzop Note Added: 0016357
2010-09-15 10:04 syzop QA => Not touched yet by developer
2010-09-15 10:04 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-09-15 10:04 syzop U4: Upstream notification of bug => Not decided
2010-09-15 10:04 syzop U4: Contributor working on this => None
2010-09-15 10:04 syzop Category ircd => documentation
2010-09-15 13:36 CoreDuo Note Added: 0016358
2010-09-15 15:07 syzop Note Added: 0016359
2010-09-15 15:08 syzop Note Edited: 0016359
2010-09-15 15:09 syzop Note Edited: 0016359
2010-09-15 15:13 syzop Note Added: 0016360
2010-09-15 15:50 CoreDuo Note Added: 0016361
2010-09-15 15:53 CoreDuo Note Edited: 0016361
2010-09-15 18:12 ohnobinki Note Added: 0016362
2010-09-15 18:14 ohnobinki Note Added: 0016363
2010-09-15 18:14 ohnobinki Status new => resolved
2010-09-15 18:14 ohnobinki Fixed in Version => 3.2.9-RC1
2010-09-15 18:14 ohnobinki Resolution open => fixed
2010-09-15 18:14 ohnobinki Assigned To => ohnobinki
2010-09-15 18:15 ohnobinki Summary badword message {} does not work => badword message {} does not apply to channel messages, docs are unclear 'bout this