View Issue Details

IDProjectCategoryView StatusLast Update
0003971unrealircdpublic2013-05-06 07:33
ReporterkatsklawAssigned Tonenolod 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.9-RC1 
Target VersionFixed in Version3.4-alpha1 
Summary0003971: Users can see own usermodes in whois
DescriptionI thought it convenient and kinda nifty that users can see their own user modes in /whois output like opers can so heres a lil patch if interested.
TagsNo tags attached.
3rd party modules

Activities

katsklaw

2010-11-30 02:49

reporter  

selfumodewhois.patch (491 bytes)

katsklaw

2010-11-30 03:11

reporter   ~0016445

not sure why "has patch" wasn't set already :/

syzop

2012-08-17 12:39

administrator   ~0017076

What do others think? Is this a good idea? What do other IRCds do?

We have to think of the general population (users, not devs or ircops): would this information be helpful to them, or would it be yet another 'useless' WHOIS line to the already large WHOIS output?

CuleX

2012-08-18 09:59

reporter   ~0017094

For users, there wouldn't be much benefit. A well-behaved client should keep track of user modes and show them on-demand/permanently somewhere anyway. Then again, I assume not all clients are well-behaved and thus there might be some value for a very small portion of users (web clients in particular come to mind). Therefore, I'd say it's not really all that important.

nenolod

2013-05-06 07:31

reporter   ~0017502

It is useful because it shows the snomask. Not all IRC clients understand the snomask.

nenolod

2013-05-06 07:32

reporter   ~0017503

http://hg.unrealircd.org/hg/unreal/rev/e19873e6bba1

Issue History

Date Modified Username Field Change
2010-11-30 02:49 katsklaw New Issue
2010-11-30 02:49 katsklaw File Added: selfumodewhois.patch
2010-11-30 03:11 katsklaw Note Added: 0016445
2010-11-30 03:11 katsklaw Status new => has patch
2012-08-17 12:39 syzop Note Added: 0017076
2012-08-18 09:59 CuleX Note Added: 0017094
2013-05-06 07:31 nenolod Note Added: 0017502
2013-05-06 07:32 nenolod Note Added: 0017503
2013-05-06 07:32 nenolod Status has patch => resolved
2013-05-06 07:32 nenolod Fixed in Version => 3.4-alpha1
2013-05-06 07:32 nenolod Resolution open => fixed
2013-05-06 07:32 nenolod Assigned To => nenolod