View Issue Details

IDProjectCategoryView StatusLast Update
0003979unrealinstallingpublic2016-12-05 10:17
ReporterohnobinkiAssigned Toohnobinki 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.9-RC1 
Target Version4.0.10Fixed in Version4.0.10 
Summary0003979: Minor Makefile cleanup/better parallel make support
DescriptionSome Makefile rules are missing the `+' prefix and $(MAKE) isn't utilized like it should be in src/Makefile. The whole MAKEFLAGS variable in src/Makefile is useless because calling $(MAKE) $(MAKEFLAGS) from within the root Makefile causes any call to $(MAKE) to carry along all $(MAKEFLAGS), thus MAKEFLAGS can/should be cleaned from src/Makefile.
Additional InformationThis patch is being queued to be committed after 3.2.9 is done.
TagsNo tags attached.
3rd party modules

Activities

ohnobinki

2010-12-21 05:51

reporter  

unreal-makefile-cleaner-recursive.patch (3,474 bytes)

syzop

2013-01-09 10:19

administrator   ~0017319

for 3.4

syzop

2016-11-10 09:26

administrator   ~0019497

Target for 4.0.9.

syzop

2016-11-14 11:20

administrator   ~0019517

I just ran 'make -j3' on freebsd and it failed, 'make' worked. Probably because of this? Worth testing after the fix ;)

syzop

2016-12-05 10:08

administrator   ~0019549

> Some Makefile rules are missing the `+' prefix and $(MAKE) isn't utilized like it should be in src/Makefile.

This was already in 4.0.x by now. (except it uses @+ instead of +@ or vice versa :D)

> The whole MAKEFLAGS variable in src/Makefile is useless because calling $(MAKE) $(MAKEFLAGS) from within the root Makefile causes any call to $(MAKE) to carry along all $(MAKEFLAGS), thus MAKEFLAGS can/should be cleaned from src/Makefile.

So only committed this cleanup..

syzop

2016-12-05 10:17

administrator   ~0019550

https://github.com/unrealircd/unrealircd/commit/6f85ec14529ec04eb2cc15957081dcc55d2d25d6

Issue History

Date Modified Username Field Change
2010-12-21 05:51 ohnobinki New Issue
2010-12-21 05:51 ohnobinki Status new => assigned
2010-12-21 05:51 ohnobinki Assigned To => ohnobinki
2010-12-21 05:51 ohnobinki File Added: unreal-makefile-cleaner-recursive.patch
2013-01-09 10:19 syzop Note Added: 0017319
2013-01-09 10:19 syzop Status assigned => has patch
2016-11-10 09:26 syzop Target Version => 4.0.8.1
2016-11-10 09:26 syzop Note Added: 0019497
2016-11-14 11:20 syzop Target Version 4.0.8.1 => 4.0.9
2016-11-14 11:20 syzop Note Added: 0019517
2016-12-04 16:26 syzop Target Version 4.0.9 => 4.0.10
2016-12-05 10:08 syzop Note Added: 0019549
2016-12-05 10:17 syzop Status has patch => resolved
2016-12-05 10:17 syzop Resolution open => fixed
2016-12-05 10:17 syzop Fixed in Version => 4.0.10
2016-12-05 10:17 syzop Note Added: 0019550