View Issue Details

IDProjectCategoryView StatusLast Update
0003981unrealinstallingpublic2010-12-22 17:03
ReporterJobe1986Assigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSFreeBSDOS Version7.0-p11
Product Version3.2.9-RC1 
Target VersionFixed in Version3.2.9-RC2 
Summary0003981: ./Config does not detec AsyncDNS on FreeBSD
DescriptionSimply put ./Config is unable to detect AsyncDNS support in curl even when it has it on FreeBSD (not using auto-installer but instead using system libs).

The reason is the detection method where ./Config expects:
[jobe@alpha ~]$ curl-config --features|grep AsynchDNS|wc -l
1

It instead gets:
[jobe@alpha ~]$ curl-config --features|grep AsynchDNS|wc -l
       1

This test can be found on line 678 of ./Config
TagsNo tags attached.
3rd party modules

Activities

ohnobinki

2010-12-22 17:03

reporter   ~0016485

Fix in CVS, will be in 3.2.9-rc2:

- Fix invalid use of 'wc -l' when detecting the AsynchDNS feature of
  libcurl which breaks compilation on FreeBSD; instead use 'grep
  -q'. Reported by Jobe (0003981), solution proposed by satmd.

Issue History

Date Modified Username Field Change
2010-12-22 12:41 Jobe1986 New Issue
2010-12-22 16:49 ohnobinki Assigned To => ohnobinki
2010-12-22 16:49 ohnobinki Status new => assigned
2010-12-22 17:03 ohnobinki Note Added: 0016485
2010-12-22 17:03 ohnobinki Status assigned => resolved
2010-12-22 17:03 ohnobinki Fixed in Version => 3.2.9-RC2
2010-12-22 17:03 ohnobinki Resolution open => fixed