View Issue Details

IDProjectCategoryView StatusLast Update
0003986unrealircdpublic2010-12-25 16:34
ReportergoldenwolfAssigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.9-RC1 
Target Version3.2.9-RC2Fixed in Version3.2.9-RC2 
Summary0003986: remote MOTD fails when URL's path component specifies directories
DescriptionUnreal fails to properly acquire MOTD file.
For Example, if MOTD is placed at:
           "http://www.example.com/motd/ircd.motd"
Unreal tries to place the motd file in ~/Unreal3.2/motd/ which doesn't exist.
If however the motd file is placed in root directory or other directory already present in Unreal3.2 folder,
            "http://www.example.com/ircd.motd"
            "http://www.example.com/src/ircd.motd"
Unreal does not complain at all.
Steps To Reproduce1) Add a MOTD url in unrealircd.conf where motd file is placed in non-root directory. ie. motd "http://dl.dropbox.com/u/1673773/ircd.motd";

2) Rehash and observe the Unreal complain something like,
Notice -- error: Unable to create file 'u/1673773/ircd.motd': No such file or directory.
TagsNo tags attached.
3rd party modules

Activities

Stealth

2010-12-24 22:57

reporter   ~0016510

Already implemented in CVS

ohnobinki

2010-12-25 00:30

reporter   ~0016511

Actually, this is a stupid bug I wrote into the remote MOTD code. I'm attaching a patch which fixes this in a few seconds.

ohnobinki

2010-12-25 00:33

reporter  

unreal-3986-motd-broken-caching.patch (4,052 bytes)

ohnobinki

2010-12-25 16:34

reporter   ~0016512

In CVS, will be in 3.2.9-rc2:

- Fix remote MOTDs for URLs whose path components contain
  subdirectories, in the process much simplifying my remote MOTD
  code. Reported by goldenwolf (0003986).

Thanks for the report and debugging this! :-)

Issue History

Date Modified Username Field Change
2010-12-24 22:38 goldenwolf New Issue
2010-12-24 22:57 Stealth Relationship added duplicate of 0001507
2010-12-24 22:57 Stealth Note Added: 0016510
2010-12-24 22:57 Stealth Status new => closed
2010-12-24 22:57 Stealth Resolution open => fixed
2010-12-24 22:57 Stealth Fixed in Version => 3.2.9-RC1
2010-12-25 00:30 ohnobinki Note Added: 0016511
2010-12-25 00:30 ohnobinki Assigned To => ohnobinki
2010-12-25 00:30 ohnobinki Status closed => new
2010-12-25 00:30 ohnobinki Resolution fixed => open
2010-12-25 00:30 ohnobinki Fixed in Version 3.2.9-RC1 =>
2010-12-25 00:30 ohnobinki Target Version => 3.2.9-RC2
2010-12-25 00:33 ohnobinki Relationship deleted 0001507
2010-12-25 00:33 ohnobinki File Added: unreal-3986-motd-broken-caching.patch
2010-12-25 16:34 ohnobinki Note Added: 0016512
2010-12-25 16:34 ohnobinki Status new => resolved
2010-12-25 16:34 ohnobinki Fixed in Version => 3.2.9-RC2
2010-12-25 16:34 ohnobinki Resolution open => fixed
2010-12-25 16:34 ohnobinki Summary MOTD with remote includes => remote MOTD fails when URL's path component specifies directories