View Issue Details

IDProjectCategoryView StatusLast Update
0003993unrealircdpublic2016-02-29 14:28
ReporterAubreyAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.9-RC1 
Target VersionFixed in Version4.0.2 
Summary0003993: Add ability to hide quit messages of glined users
DescriptionWhen a user is banned from the server in any way, their quit message is "User has been banned (?line reason here)". A feature to hide the ban reason from everyone or even only non-opers would be very useful. Frequently ban messages are private and don't need to be shared with the world.
TagsNo tags attached.
3rd party modules

Activities

goldenwolf

2010-12-31 08:28

reporter   ~0016549

I see the feature being abused and don't really think there is any reason to keep the reason hidden. The reason at times can help other users (friend of the user banned) to approach the operators and clarify the issue.

Aubrey

2010-12-31 15:57

reporter   ~0016555

Server bans are (in most IRC environments) not a public issue. It also encourages opers to use glines as a "warning message" to others which isn't appropriate. A setting to turn this on or off à-la InspIRCd would be nice.

syzop

2015-07-13 22:25

administrator   ~0018492

I'm fine with this. Not so sure if I'll spend time on it, though.

syzop

2016-01-13 11:14

administrator   ~0019057

Last edited: 2016-01-13 11:15

View 3 revisions

Apparently there's a pull request and (thus) patch available https://github.com/Zoddo/unrealircd/commit/57f01ea3b9796bfb69a9cf973f87fab2bad19ef0

Don't like set::options::secret-ban-reasons, though (the name and to lesser extent place).
Haven't walked through the patch line by line but the structure/solution looks good. Not sure if it's for 4.0.1 though, want to release that soon.

blank

2016-01-13 11:58

reporter   ~0019059

Last edited: 2016-01-13 12:02

View 2 revisions

secret sounds stupid

'hide-ban-reason' does the job ;-)

also I would vote against the long 'User has been banned blah blah blah ...' string

other IRC daemons just do 'X-Lined' or similar, looks much neater

that's opinion though ;-)

(either way, can someone make a decision so that we can get this for the next release? would be real nice)

syzop

2016-02-29 14:28

administrator   ~0019112

[unreal40 1e25578] Add ability to hide quit messages of *LINEd users. Suggested by Aubrey, patch mostly from Zoddo (0003993).
https://github.com/unrealircd/unrealircd/commit/1e25578c42b6e68b87fd6b1eb73d87677c9052f9

I used the patch as a base (thanks!) and made it set::hide-ban-reason [yes|no] (the default is no). I'll update the wiki as well.

The zline case (already) showed the reason if user was not really online yet, I updated the other *LINE cases as well. This may help to people who repeatedly try to connect and somehow miss the server notice.

I did not integrate the example.conf stuff

Issue History

Date Modified Username Field Change
2010-12-31 04:27 Aubrey New Issue
2010-12-31 08:28 goldenwolf Note Added: 0016549
2010-12-31 15:57 Aubrey Note Added: 0016555
2015-07-13 22:25 syzop Note Added: 0018492
2015-07-13 22:25 syzop Status new => acknowledged
2016-01-13 11:14 syzop Note Added: 0019057
2016-01-13 11:14 syzop Status acknowledged => has patch
2016-01-13 11:15 syzop Note Edited: 0019057 View Revisions
2016-01-13 11:15 syzop Note Edited: 0019057 View Revisions
2016-01-13 11:58 blank Note Added: 0019059
2016-01-13 12:02 blank Note Edited: 0019059 View Revisions
2016-02-29 14:28 syzop Note Added: 0019112
2016-02-29 14:28 syzop Status has patch => resolved
2016-02-29 14:28 syzop Fixed in Version => 4.0.2
2016-02-29 14:28 syzop Resolution open => fixed
2016-02-29 14:28 syzop Assigned To => syzop