View Issue Details

IDProjectCategoryView StatusLast Update
0004007unrealdocumentationpublic2011-02-23 02:35
ReporterwargAssigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.9-RC1 
Target VersionFixed in Version3.2.9-RC2 
Summary0004007: Documentation does not say that +t allows a halfop to change the topic
DescriptionMaybe this is nitpicking, but the documentation for channel mode +t has always said "Only chanops can set topic".

I think clarity is important, and should say "Only channel half-operators and higher can set the topic".
Additional InformationOpinion: Personally, I don't like that channel half-operators can set topic on +t (I mean, if they can't kick other half-operators and such, why should they be permitted to change the topic?), but that's beside the point.
TagsNo tags attached.
3rd party modules

Activities

CuleX

2011-02-22 13:09

reporter   ~0016600

I think halfops are limited enough as-is. Just change the message so that halfops can change the topic with +t and be done with it.

ohnobinki

2011-02-23 02:29

reporter   ~0016601

For now, at least, the behavior of chmode +t can't be changed so dramatically. So, this will be a documentation bug. (I.e., even though this behavior of halfops being able to set the topic is undocumented, it is intended. Also, one half of the documentation -- the HELPOP docs -- correctly state that ``Only +hoaq may change the topic [h]''.)

I don't think that chmode +t will ever prevent halfops from setting the topic, but if you still are interested in that please open another bug.

Documentation is fixed in CVS:
- Fix documentation about channel mode +t and halfops, thanks warg (0004007).

Thanks for reporting this inconsistency :-).

Issue History

Date Modified Username Field Change
2011-02-19 03:07 warg New Issue
2011-02-22 13:09 CuleX Note Added: 0016600
2011-02-23 02:29 ohnobinki Note Added: 0016601
2011-02-23 02:29 ohnobinki Status new => resolved
2011-02-23 02:29 ohnobinki Fixed in Version => 3.2.9-RC2
2011-02-23 02:29 ohnobinki Resolution open => fixed
2011-02-23 02:29 ohnobinki Assigned To => ohnobinki
2011-02-23 02:35 ohnobinki Summary The channel mode +t permits more than just channel operators to change the topic. => Documentation does not say that +t allows a halfop to change the topic