View Issue Details

IDProjectCategoryView StatusLast Update
0004028unrealircdpublic2011-07-18 12:53
ReporterPlatziiAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindows ServerOS VersionServer 2008
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC2 
Summary0004028: Rehash from commandline doesn't rehash MOTD
DescriptionWhen rehashing from windows commandline, the MOTD doesn't get rehashed. This only happens on a Windows OS.

I tried this on 2 Windows hosts and had twice the same result.
Steps To ReproduceCheck /MOTD
Change ircd.motd
Use unreal.exe rehash
Check /MOTD
Notice that MOTD isn't rehashed
Additional InformationUsing 3.2.8.1 Win32 SSL
Installed as service
TagsNo tags attached.
3rd party modules

Activities

Platzii

2011-07-13 21:42

reporter   ~0016687

Btw, config does rehash. Only MOTD doesn't.

katsklaw

2011-07-14 03:25

reporter   ~0016688

Rehash isn't designed to rehash motd's, there is a separate command, /rehash -motd The rc script is not written to rehash motd's or any other /rehash option. This isn't a bug, but a lack of ability.

Platzii

2011-07-14 08:54

reporter   ~0016693

But in the unix-version it does rehash the MOTD...

syzop

2011-07-18 12:53

administrator   ~0016700

Yes, REHASH should rehash all motd&rules etc, this rule was imposed a couple of years ago but at some places the code is still using the old (inconsistent) logic of having part of the MOTD/RULES/etc being re-read (eg: tld) while others are not re-read.

- Win32: fix rehash from the command line not working, reported by Platzii
  (0004028).

Issue History

Date Modified Username Field Change
2011-07-13 21:16 Platzii New Issue
2011-07-13 21:42 Platzii Note Added: 0016687
2011-07-14 03:25 katsklaw Note Added: 0016688
2011-07-14 08:54 Platzii Note Added: 0016693
2011-07-18 12:53 syzop Note Added: 0016700
2011-07-18 12:53 syzop Status new => resolved
2011-07-18 12:53 syzop Fixed in Version => 3.2.9-RC2
2011-07-18 12:53 syzop Resolution open => fixed
2011-07-18 12:53 syzop Assigned To => syzop