View Issue Details

IDProjectCategoryView StatusLast Update
0004074unrealircdpublic2012-09-24 09:59
Reporterstatic-xAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSFreeBSDOS Version8.2-STABLE
Product Version3.2.9 
Target VersionFixed in Version3.2.9 
Summary0004074: Curl
DescriptionSeems Remote includes cant be installed on my system. I get this errror

configure: error: in `/usr/home/testdev/Unreal3.2':
configure: error: You asked for libcURL (remote includes) support, but it can't be found at /usr/home/testdev/curl
See `config.log' for more details.

ircd would configure if I dont enable that option
TagsNo tags attached.
3rd party modules

Activities

Stealth

2012-01-17 14:15

reporter   ~0016866

Do you have the curl source extracted to /usr/home/testdev/curl? Unreal won't do this for you, which is why it asks for the path to curl during ./Config

ohnobinki

2012-01-18 01:11

reporter   ~0016867

Please also attach the config.log file after an unsuccessful ./configure.

You should really install libcurl using ports or whatever FreeBSD's package manager is instead of installing it locally.

static-x

2012-01-19 04:30

reporter   ~0016870

Will do

static-x

2012-05-12 04:02

reporter   ~0017004

Well libcurl is installed

[19:49](root@tornado)[~]# curl --version curl 7.21.3 (i386-portbld-freebsd8.2) libcurl/7.21.3 OpenSSL/1.0.0
zlib/1.2.3
Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s rtsp smtp smtps telnet tftp
Features: IPv6 Largefile NTLM SSL libz

static-x

2012-05-12 04:03

reporter  

config.log (93,593 bytes)

nenolod

2012-05-12 23:01

reporter   ~0017005

It's because -lidn is missing. I think the check is broken.

nenolod

2012-05-12 23:03

reporter   ~0017006

Please provide curl-config --cflags --libs output in a comment.

static-x

2012-05-13 05:13

reporter   ~0017007

curl-config --cflags --libs -I/usr/local/include -L/usr/local/lib -lcurl -rpath=/usr/local/lib -L/usr/local/lib -lssl -lcrypto -lssl -lcrypto -lz

syzop

2012-05-20 17:25

administrator   ~0017008

As nenolod says:

/usr/bin/ld: cannot find -lidn
configure:7069: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "unrealircd"
| #define PACKAGE_TARNAME "unrealircd"
etc.. curl..

I'm not sure where the -lidn is coming from.
Your curl-config paste suggest it's not coming from curl.

--
configure:7049: checking curl_easy_init() in -L/usr/home/zcuchat/curl/lib -lcurl -lcares -lidn -lssl -lcrypto -lssl -lcrypto -lz
--
This suggests that it's coming from c-ares ?

Or from openssl?

static-x

2012-05-20 20:53

reporter   ~0017009

I mean it worked fine until this version.

nenolod

2012-05-29 23:01

reporter   ~0017010

yes, c-ares is pulling it in. i think he is using system c-ares, which is compiled against libidn, but ports didn't pull in libidn when he pkg_add'd it (which is not surprising because freebsd package management is kind of poorly engineered)

static-x

2012-06-09 18:42

reporter   ~0017022

What can we do to get this to work? or what can i do change on my end to get tit to work

nenolod

2012-06-11 07:36

reporter   ~0017023

you should be able to get it working by installing libidn since system c-ares depends on it. alternatively, you could try --without-system-curl configure option.

static-x

2012-09-20 06:52

reporter   ~0017126

I've tested this with the nightly builds 9-19 and it worked fine with remote include but if I download 3.2.9 from the website it doesnt work.

syzop

2012-09-24 09:58

administrator   ~0017128

Thanks for the update.

I'm considering this fixed then.

Also, it seemed more of a FreeBSD issue than Unreal, but I'm glad the nightly build resolves things for you :)

Issue History

Date Modified Username Field Change
2012-01-17 07:44 static-x New Issue
2012-01-17 14:15 Stealth Note Added: 0016866
2012-01-18 01:11 ohnobinki Note Added: 0016867
2012-01-18 01:11 ohnobinki Status new => feedback
2012-01-19 04:30 static-x Note Added: 0016870
2012-05-12 04:02 static-x Note Added: 0017004
2012-05-12 04:03 static-x File Added: config.log
2012-05-12 23:01 nenolod Note Added: 0017005
2012-05-12 23:03 nenolod Note Added: 0017006
2012-05-13 05:13 static-x Note Added: 0017007
2012-05-20 17:25 syzop Note Added: 0017008
2012-05-20 20:53 static-x Note Added: 0017009
2012-05-29 23:01 nenolod Note Added: 0017010
2012-06-09 18:42 static-x Note Added: 0017022
2012-06-11 07:36 nenolod Note Added: 0017023
2012-09-20 06:52 static-x Note Added: 0017126
2012-09-24 09:58 syzop Note Added: 0017128
2012-09-24 09:59 syzop Status feedback => resolved
2012-09-24 09:59 syzop Fixed in Version => 3.2.9
2012-09-24 09:59 syzop Resolution open => fixed
2012-09-24 09:59 syzop Assigned To => syzop