View Issue Details

IDProjectCategoryView StatusLast Update
0004082unrealircdpublic2013-05-20 00:33
ReporternenolodAssigned Tonenolod 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4-alpha1 
Summary0004082: remove TOKEN support
Descriptionhi,

we should probably remove TOKEN support. the rationale for TOKEN has long since been superseded by better methods such as ziplinks, and only add very large amounts of complexity to the code.
TagsNo tags attached.
3rd party modules

Relationships

child of 0004188 closed Unreal 3.4 alpha1 blockers 

Activities

syzop

2012-01-28 21:35

administrator   ~0016900

I don't see this happening in the foreseeable future. It won't be done in 3.2 as it's a (way) too major change, and we don't have resources to do 3.3/4.0 parallel development.
Plus, I disagree with you on the "very large amounts of complexity" and the priority.

katsklaw

2012-02-03 09:02

reporter   ~0016902

Oddly enough, I agree with both of you ;)

TOKENS aren't really needed in today's irc world. Especially with bandwidth getting faster.and cheaper and for other already stated reasons. I also agree with the priority, complexity and timeline suggested by syzop.

nenolod

2013-01-14 11:10

reporter   ~0017366

I am going to go ahead and remove TOKEN in 3.4 because it adds a lot of complexity to send.c and we're only required to link to 3.2, not speak the entirety of the 3.2 link protocol.

syzop

2013-01-14 14:12

administrator   ~0017370

Yup, go ahead. I'm OK with this protocol change.

nenolod

2013-05-13 07:40

reporter   ~0017552

Status on this: TOKEN is gone, some infrastructure remains in the core for tokens still, such as hunt_server_token() and hunt_server_token_quiet().

Going to knock those out tomorrow, then close this bug after validating link compatibility is still there...

nenolod

2013-05-14 00:37

reporter   ~0017556

hunt_server_token(), hunt_server_token_quiet() now gone.

going to do a last pass on the send.c stuff.

nenolod

2013-05-14 05:15

reporter   ~0017558

remaining:

send.c:

sendto_serv_butone_tok, sendto_serv_butone_tok_opt, sendto_channelprefix_butone_tok

packet.c:

add_Command needs to have token field removed (logic itself is gone)

msg.h

TOK_ defines need to be killed

modules:

TOK_ defines need to be killed

nenolod

2013-05-19 22:36

reporter   ~0017601

grawity provided some patches killing sendto_serv_butone_token(), i have committed them.

nenolod

2013-05-19 22:58

reporter   ~0017602

sendto_channelprefix_butone_tok() removed.

nenolod

2013-05-19 23:34

reporter   ~0017604

Everything but sendto_serv_butone_token_opt() is done.

nenolod

2013-05-20 00:33

reporter   ~0017607

This patch removes the last bits of TOKEN support.

http://hg.unrealircd.org/hg/unreal/rev/bfb5f6842034

Thanks to everyone that helped with this!

Issue History

Date Modified Username Field Change
2012-01-22 21:52 nenolod New Issue
2012-01-28 21:30 syzop Priority high => low
2012-01-28 21:35 syzop Note Added: 0016900
2012-02-03 09:02 katsklaw Note Added: 0016902
2013-01-14 11:10 nenolod Note Added: 0017366
2013-01-14 14:12 syzop Note Added: 0017370
2013-01-14 14:14 syzop Assigned To => nenolod
2013-01-14 14:14 syzop Status new => assigned
2013-05-12 22:30 nenolod Relationship added child of 0004188
2013-05-13 07:40 nenolod Note Added: 0017552
2013-05-14 00:37 nenolod Note Added: 0017556
2013-05-14 05:15 nenolod Note Added: 0017558
2013-05-19 22:36 nenolod Note Added: 0017601
2013-05-19 22:58 nenolod Note Added: 0017602
2013-05-19 23:34 nenolod Note Added: 0017604
2013-05-20 00:33 nenolod Note Added: 0017607
2013-05-20 00:33 nenolod Status assigned => resolved
2013-05-20 00:33 nenolod Fixed in Version => 3.4-alpha1
2013-05-20 00:33 nenolod Resolution open => fixed