View Issue Details

IDProjectCategoryView StatusLast Update
0004095unrealircdpublic2015-08-08 16:51
ReporterNathAssigned Tosyzop 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.9 
Target VersionFixed in Version3.4-beta1 
Summary0004095: /who and /names with IRCops.
DescriptionThis really is minor, but I fail to see why when /names #channel is used externally, by anyone but a NetAdmin, it hides all users who are +i, but /who #channel can be used by any IRCop externally anyway to view users who are +i or not.

Not a massive problem, but the restriction seems redundant.
TagsNo tags attached.
3rd party modules

Activities

nenolod

2012-03-07 03:38

reporter   ~0016946

Agreed. I will try to get a patch going for this in a day or two.

nenolod

2012-03-25 21:18

reporter   ~0016962

I am unable to reproduce this. Are you certain you are NetAdmin?

Nath

2012-03-27 14:18

reporter   ~0016964

I can be NetAdmin, or any other IRCop, I can use my test net. What part are you unable to reproduce? Being able to see /names output as a netadmin externally from the given channel? Or not seeing them as non netadmin? Or unable to view people in the channel externally using a /who #chan as any ircop?

nenolod

2012-03-30 03:08

reporter   ~0016966

I can see NAMES output as NetAdmin when off the channel. I can't see any obvious logic errors in the code, either.

Nath

2012-04-04 13:42

reporter   ~0016968

Yes that's not what I'm confused about. I'm saying that a NetAdmin can use both /names and /who to view people in a channel who are +i without being in it. Any other oper can only use /who to achieve this. I see no reason why all the opers other than NetAdmin can't see +i users in a channel when using /names but can see them when they do a /who #chan, what's the point?

nenolod

2012-04-06 00:45

reporter   ~0016970

I think instead, the appropriate way of handling this is to introduce a new permission, which netadmin would imply.

This would allow for more customization and control over information visibility anyway. Do you agree?

syzop

2015-08-08 16:51

administrator   ~0018624

I think this is fixed in 3.4.x. We use the same "can ircop see this / user see this" type of hooks/callbacks

Issue History

Date Modified Username Field Change
2012-03-06 21:18 Nath New Issue
2012-03-07 03:38 nenolod Note Added: 0016946
2012-03-25 21:18 nenolod Note Added: 0016962
2012-03-27 14:18 Nath Note Added: 0016964
2012-03-30 03:08 nenolod Note Added: 0016966
2012-04-04 13:42 Nath Note Added: 0016968
2012-04-06 00:45 nenolod Note Added: 0016970
2015-08-08 16:51 syzop Note Added: 0018624
2015-08-08 16:51 syzop Status new => resolved
2015-08-08 16:51 syzop Fixed in Version => 3.4-beta1
2015-08-08 16:51 syzop Resolution open => fixed
2015-08-08 16:51 syzop Assigned To => syzop