View Issue Details

IDProjectCategoryView StatusLast Update
0004102unrealircdpublic2012-10-16 11:30
ReportermaxarturoAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntelOSWindows XPOS VersionSP3
Product Version3.2.9 
Target VersionFixed in Version3.2.10-rc1 
Summary0004102: MOTD date
DescriptionIncorrect date is displayed when reading the file ircd.motd. Displays "1/1/1970 4:00".
Steps To ReproduceConnecting to the server.
TagsNo tags attached.
3rd party modulesNone

Activities

maxarturo

2012-04-05 09:28

reporter  

ircd.motd (20 bytes)

syzop

2012-04-09 10:58

administrator   ~0016978

Confirmed. Windows-only issue.

syzop

2012-10-16 11:30

administrator   ~0017181

Thanks for the report, this issue has now been resolved.

http://hg.unrealircd.com/hg/unreal/rev/7263bbdde9a0

- Windows: fix MOTD file always showing a date of 1/1/1970, reported
  by maxarturo (0004102).

caused by unreal_getfilemodtime() using CreateFile() to open the file in exclusive mode instead of shared read...

Issue History

Date Modified Username Field Change
2012-04-05 09:28 maxarturo New Issue
2012-04-05 09:28 maxarturo File Added: ircd.motd
2012-04-09 10:58 syzop Note Added: 0016978
2012-04-09 10:58 syzop Status new => confirmed
2012-10-06 12:52 syzop Assigned To => syzop
2012-10-06 12:52 syzop Status confirmed => assigned
2012-10-16 11:30 syzop Note Added: 0017181
2012-10-16 11:30 syzop Status assigned => resolved
2012-10-16 11:30 syzop Fixed in Version => 3.2.10-rc1
2012-10-16 11:30 syzop Resolution open => fixed