View Issue Details

IDProjectCategoryView StatusLast Update
0004129unrealircdpublic2012-10-15 15:06
ReporternenolodAssigned Tosyzop 
PriorityhighSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.10-rc1 
Summary0004129: Windows builds shouldn't use USE_POLL
DescriptionWSAPoll() is only available on Vista or better, so we should probably disable USE_POLL there, since WSAPoll() just wraps select() anyway.

While there, we should set up FD_SETSIZE to match MAXCONNECTIONS + 10 (for overhead, curl, c-ares, etc).
TagsNo tags attached.
3rd party modules

Activities

syzop

2012-10-15 15:05

administrator   ~0017163

- Disable USE_POLL on Windows, since it doesn't work with XP and has
  no advantage anyway. Reported by nenolod (0004129).
Done. It didn't compile anyway (don't care right now either ;p).

As for your 2nd request:
[quote]While there, we should set up FD_SETSIZE to match MAXCONNECTIONS + 10 (for overhead, curl, c-ares, etc).[/quote]
Do you mean for Windows? I guess not, since on Windows FD_SETSIZE is already 16k. Also MAXCONNECTIONS is 4096 on windows so I doubt the 10 matters much.
Or on *NIX? But on *NIX we always use poll now (not to mention FD_SETSIZE setting is unused on f.e. Liux), so the FD_SETSIZE shouldn't matter anymore.

Another note: see MAXCLIENTS, which is used to limit the # of clients with a slightly lower value than MAXCONNECTIONS. It's currently -4.

In any case, not urgent for 3.2.10.

syzop

2012-10-15 15:06

administrator   ~0017165

http://hg.unrealircd.com/hg/unreal/rev/789a093eabec

- Disable USE_POLL on Windows, since it doesn't work with XP and has
no advantage anyway. Reported by nenolod (0004129).

Issue History

Date Modified Username Field Change
2012-10-14 15:16 nenolod New Issue
2012-10-15 15:05 syzop Note Added: 0017163
2012-10-15 15:05 syzop Issue cloned: 0004130
2012-10-15 15:06 syzop Note Added: 0017165
2012-10-15 15:06 syzop Status new => resolved
2012-10-15 15:06 syzop Fixed in Version => 3.2.10-rc1
2012-10-15 15:06 syzop Resolution open => fixed
2012-10-15 15:06 syzop Assigned To => syzop