View Issue Details

IDProjectCategoryView StatusLast Update
0004137unrealinstallingpublic2013-01-09 09:10
ReporterwargAssigned Tosyzop 
PriorityhighSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSGNU/Linux, *BSDOS VersionMany
Product Version3.2.10-rc1 
Target VersionFixed in Version3.2.10 
Summary0004137: curlinstall fails if libssh2 devel is available on the system.
Descriptionhttp://forums.unrealircd.com/viewtopic.php?f=38&t=7657&p=36054#p36054

RE: 1) *NIX: Use the ./curlinstall script, see if it delivers a working curl that can be used during ./Config

It seems that on GNU/Linux and *BSD (and probably OS X), if libssh2 devel is available, cURL's configure will fail with "libssh2.h:443: error: previous declaration of 'libssh2_free' was here." The resolution to fix this is to append --without-libssh2 to cURL's configure line in the curlinstall script.
Steps To ReproduceInstall libssh2 development packages on your GNU/Linux or *BSD system, then try the curlinstall script.
Additional InformationIf libssh2 devel isn't available, or we append --without-libssh2 to cURL's configure line, then the curlinstall script appears to be WAI.

I've tested on several GNU/Linux distribution releases and FreeBSD.

Also, maybe we should simply disable any cURL features that are unnecessary for UnrealIRCd?
TagsNo tags attached.
3rd party modules

Activities

warg

2012-10-26 18:46

reporter  

curlinstall.patch (447 bytes)

syzop

2012-10-28 09:04

administrator   ~0017213

Thanks for testing, we certainly want a workable curlinstall script ;)

Hmmm.. so basically we should workaround a curl bug.
I was going to say, let's add the --disable- feature to the command if it's a non-used protocol, but ssh:// sounds pretty neat (I wasn't aware of it), so that would be a shame.

I see the curlinstall script uses http://www.unrealircd.com/files/curl-latest.tar.gz
Interesting.. I haven't updated that file since July 2010.

I now replaced it with the current latest curl, could you check if the curlinstall script works now?

Ideally the curlinstall script should fetch curl from the curl site itself.
Perhaps leave the bug open as a TODO item for that.

syzop

2012-10-28 09:54

administrator   ~0017215

Tested on debian 6 with libssh devel package & updated, works now.
Let me know if you have the same result(s).

warg

2012-10-29 02:24

reporter   ~0017217

It seems to work on FreeBSD 9.0-RELEASE and various GNU/Linux distribution releases in my VirtualBox. Thanks, Syzop. :)

xaero

2012-10-29 14:50

reporter   ~0017218

I successfully ran curlinstall on OS X.8 w/ the following pre-requisites:

- Mercurial OS X port from their website
- MacPorts 2.1.2
- XCode from Apple AppStore
- Command Line Tools from Download Tab in preferences.
- (in terminal) 'port install wget'

From there, an hg clone can be preformed and curlinstall will build in it's entirety.

Issue History

Date Modified Username Field Change
2012-10-26 18:46 warg New Issue
2012-10-26 18:46 warg File Added: curlinstall.patch
2012-10-28 09:04 syzop Note Added: 0017213
2012-10-28 09:54 syzop Note Added: 0017215
2012-10-29 02:24 warg Note Added: 0017217
2012-10-29 14:50 xaero Note Added: 0017218
2013-01-09 09:09 syzop Status new => resolved
2013-01-09 09:09 syzop Fixed in Version => 3.2.10
2013-01-09 09:09 syzop Resolution open => fixed
2013-01-09 09:09 syzop Assigned To => syzop