View Issue Details

IDProjectCategoryView StatusLast Update
0004143unrealircdpublic2013-01-17 21:32
ReporterCronusAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSDebianOS Version6.0.4
Product Version3.2.9 
Target VersionFixed in Version3.2.10.1 
Summary0004143: /rehash -global Does not rehash all servers across the network
DescriptionI recently introduced remote includes which made /rehash -global more liking in my case. I tried it, it does not rehash any server except the server I am on. I have check with being a netadmin on a linked leaf and i get no notices of rehash. Nor Do I see my FTP get hit for the remote includes
Steps To ReproduceHave 2+ servers linked
Connect and oper on both servers
issue /rehash -global
Only your server you issue the command from will work.
Additional InformationPerhaps while looking at this look into making wildcarded rehashes work.
Such as. /rehash *.this.domain.tld would rehash all matching entries.
(Not sure if A seperate feature request should be made for this if so, I shall.)
TagsNo tags attached.
3rd party modules

Activities

syzop

2012-12-15 20:58

administrator   ~0017269

Sorry, I didn't have time to verify your bug yet, hopefully someone else can.
As for your wildcard suggestion, this is in 0004015.

wolfwood

2012-12-20 10:31

reporter   ~0017276

I can verify there's a problem with this feature. It rehashes more than the server I'm connected though, just not all of them. Personally I just use a script to issues a command to rehash all the servers, but it would be nice if this feature worked.

syzop

2013-01-09 19:43

administrator   ~0017343

'/rehash -global' did often not rehash all servers. Reported by Cronus (0004143).

Thanks, fixed in both 3.2 & 3.4
http://hg.unrealircd.com/hg/unreal/rev/20c7cad7aad1
http://hg.unrealircd.com/hg/unreal/rev/5ba6ced7e94f

Issue History

Date Modified Username Field Change
2012-11-12 02:44 Cronus New Issue
2012-12-15 20:58 syzop Note Added: 0017269
2012-12-20 10:31 wolfwood Note Added: 0017276
2013-01-09 19:43 syzop Note Added: 0017343
2013-01-09 19:43 syzop Status new => resolved
2013-01-09 19:43 syzop Fixed in Version => 3.2.10
2013-01-09 19:43 syzop Resolution open => fixed
2013-01-09 19:43 syzop Assigned To => syzop
2013-01-17 21:32 syzop Fixed in Version 3.2.10 => 3.2.10.1