View Issue Details

IDProjectCategoryView StatusLast Update
0004164unrealircdpublic2013-05-26 11:06
ReporterCaseyAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionduplicate 
Product Version4.0-devel 
Target VersionFixed in Version 
Summary0004164: new channel modes
DescriptionPermanent Channels, and also perhaps in the conf to have permanent channels on startup like InspIRCd


Op Moderated for help channels etc where users can not see what other users are saying and can only see what the ops are saying.

for example +z - messages blocked by +m +b and quiet are instead sent to ops.
TagsNo tags attached.
3rd party modules

Activities

ShawnSmith

2013-01-24 00:03

reporter   ~0017386

If Permanent channels are implemented instead of being able to define them in the config, I think that any channel marked with the permanent channel mode should be written to a database on shutdown and/or rehash, so any changes that are made between the time the config is written and the time the ircd is shutdown will take effect.

I think channel mode +P is pretty commonly used for this, so we should probably use that if this is implemented.


Also for OP Moderated since +z is used already for SSL, perhaps we could use +U, which was going to be used in InspIRCd for the same purpose in 2.1 before that got canceled in favor of fixing 2.0

katsklaw

2013-01-25 05:57

reporter   ~0017387

+1 for persistent channel. +P would be better as +z is already taken and its used in other ircds.

-1 for more +Uness. I've been an ircop for almost 20 years and never used or seen the need for +u

Not sure what you mean "op moderated" as chanops have always been able to moderate a channel. I fail to see the harm in letting users see other user in the first place.

nenolod

2013-05-06 06:12

reporter   ~0017488

katsklaw: +z is +u done right, instead of hiding users, it simply makes non-voiced messages go to ops only.

i am planning on just making +u work that way in the 3.4 series, my limited research shows that nobody really uses +u as it stands anyway. i might change it to +z at that time, i am not sure.

it all depends on how compatible we have to be with 3.2.

KindOne

2013-05-08 22:01

reporter   ~0017535

Permanent channels has already been suggested - http://bugs.unrealircd.org/view.php?id=4117

syzop

2013-05-26 11:06

administrator   ~0017686

+P (permanent) is in 0004117

and +u is already discussed at a variety of places (too many), the latest central discussion is in 0004160

So I'm closing this one, feel free to post in 0004160 on +u-like ideas as we have to decide there what to do with it..

Issue History

Date Modified Username Field Change
2013-01-20 23:23 Casey New Issue
2013-01-24 00:03 ShawnSmith Note Added: 0017386
2013-01-25 05:57 katsklaw Note Added: 0017387
2013-05-06 06:12 nenolod Note Added: 0017488
2013-05-08 22:01 KindOne Note Added: 0017535
2013-05-26 11:06 syzop Note Added: 0017686
2013-05-26 11:06 syzop Status new => resolved
2013-05-26 11:06 syzop Resolution open => duplicate
2013-05-26 11:06 syzop Assigned To => syzop