View Issue Details

IDProjectCategoryView StatusLast Update
0004204unrealinstallingpublic2013-05-20 09:25
ReportergrawityAssigned Tonenolod 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.4-alpha1 
Target VersionFixed in Version3.4-alpha1 
Summary0004204: Default value for LISTEN_SIZE is empty, breaks build
DescriptionWhen I run ./Config and keep giving the default answers with [Enter], I end up with LISTEN_SIZE being defined to nothing:

include/setup.h:201:#define LISTEN_SIZE

This doesn't compile well:

s_bsd.c:445:32: error: expected expression before ‘)’ token
  result = listen(listener->fd, LISTEN_SIZE);
                                ^

Looks like not everyone can reproduce it, but:

05:45 (kaniini) at any rate, LISTEN_SIZE should be set to SOMAXCONN
TagsNo tags attached.
3rd party modules

Activities

Issue History

Date Modified Username Field Change
2013-05-20 04:47 grawity New Issue
2013-05-20 09:25 nenolod Note Added: 0017617
2013-05-20 09:25 nenolod Status new => resolved
2013-05-20 09:25 nenolod Fixed in Version => 3.4-alpha1
2013-05-20 09:25 nenolod Resolution open => fixed
2013-05-20 09:25 nenolod Assigned To => nenolod