View Issue Details

IDProjectCategoryView StatusLast Update
0004209unrealircdpublic2013-05-24 23:51
ReporternenolodAssigned Tonenolod 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version3.4-alpha1Fixed in Version3.4-alpha1 
Summary0004209: race-condition (?!) with exit_one_client()
Descriptionseems we can corrupt ourselves by constantly connecting and squitting a server.

we should like, take a look at this with purify and stuff.
TagsNo tags attached.
3rd party modules

Relationships

child of 0004188 closed Unreal 3.4 alpha1 blockers 

Activities

nenolod

2013-05-24 23:03

reporter   ~0017664

Purify says -- unsurprisingly -- use of a rogue pointer in exit_one_client().

Valgrind says this:

==5144== Invalid write of size 8
==5144== at 0x15A30C: sendto_common_channels (send.c:539)
==5144== by 0x14EAA7: exit_one_client (s_misc.c:532)
==5144== by 0x14EC5F: recurse_remove_clients (s_misc.c:488)
==5144== by 0x14EE6A: exit_client (s_misc.c:514)
==5144== by 0x14CDE6: fd_select (s_dispatch.c:412)
==5144== by 0x11F09A: main (ircd.c:1666)
==5144== Address 0x13cfe5a0 is not stack'd, malloc'd or (recently) free'd

Hmm.

nenolod

2013-05-24 23:51

reporter   ~0017665

Cannot reproduce after this change: http://hg.unrealircd.org/hg/unreal/rev/0f747f0295fe

Issue History

Date Modified Username Field Change
2013-05-21 12:04 nenolod New Issue
2013-05-21 12:05 nenolod Relationship added child of 0004188
2013-05-24 23:03 nenolod Note Added: 0017664
2013-05-24 23:51 nenolod Note Added: 0017665
2013-05-24 23:51 nenolod Status new => resolved
2013-05-24 23:51 nenolod Fixed in Version => 3.4-alpha1
2013-05-24 23:51 nenolod Resolution open => fixed
2013-05-24 23:51 nenolod Assigned To => nenolod