View Issue Details
|ID||Project||Category||View Status||Date Submitted||Last Update|
|0004232||unreal||ircd||public||2013-08-10 04:49||2014-05-30 19:32|
|Platform||Linux||OS||Ubuntu||OS Version||12.04 x86_64|
|Fixed in Version||3.4-alpha1|
|Summary||0004232: Change "Rejoining because of user@host change" text on part message to "Changing Host"|
|Description||Change the text used on the set::allow-userhost-change setting when set to force-rejoin. When a user changes his/her host, the text will be changed from what it is now to just "Changing Host". Also if possible, the client could be shown as quitting instead of parting, although I don't really care about that feature (I just wanted to mention it).|
|Tags||No tags attached.|
|3rd party modules||m_sanick textban|
I don't see a need to change the text.
Could you provide justification for such a change?
How is sending a QUIT instead of a PART better?
Could sending a QUIT instead possibly be worse?
Could a QUIT vs PART cause issues or race conditions?
How will QUIT be handled between servers?
Will a server need to QUIT a client and reintroduce the client as a fresh connection?
How would s2s handle user timestamps if the user is QUIT and reintroduced?
You don't have to change the part sequence to a quit sequence, because I said that wasn't really needed but I would mention it.
I just want the text changed from what it is now to "Changing Host", something that is a lot more simple and shorter than saying rejoining because of user@host change. You guys told me that if I change this on my own that you guys won't support me anymore, so this is the only way to get it officially changed.
||Other than "It's shorter" I fail to see any real reasoning. I cannot recall anyone else who has requested something shorter either here, on IRC, or the forums.|
It seems nenolod changed (in Unreal 3.4.x devel branch) PART/JOIN to QUIT/JOIN in http://hg.unrealircd.com/hg/unreal/rev/df429d68f918 -- personally I would rather have preferred to see it as an option, though. He just ripped the PART/JOIN thing out :p.
As for changing the wording. In the same commit, nenolod changed it to 'Changing host'.
I think the original message was more clear, but the new message is smaller and prettier. Can't say I care much about this :P
I don't see a need to change either. Saying "simple and shorter" implies that the current method is long and complex which it isn't. IMVHO, this is another minor change that yields little or no advantage.
As far as quit vs part, I feel part is better. Part is all that is needed to keep channels and other clients in sync. Sending a quit could have adverse effects on client bots and services as they may require the user log in again "because they quit".
I see the reason for the change was because other ircds do it, that doesn't make it "better" or more correct. Unreal isn't other ircds and in fact, if all ircds did the exact same things, we would only need 1. I think it's bad form to do something based solely on the fact that others do it. We aren't sheep so we don't need to jump off the cliff just because others have.
I totally agree, especially on the 'other ircds do it this way so we must do it too' criticism.
I've seen a few changes or suggestions about making things 'like in other ircds', to me that's fine if it's an improvement, but to those people I say: remember that sometimes.. yes sometimes.. we think a little about things too! and then we MAY just decide different on things. There are often pro's and con's on something, and we may just weigh them different than other ircds do and make another decision than them.
Now, this doesn't have that much to do with the original report anymore, as said I'm fine with a text change (or not) ;p.
It's "Changing host" in 3.4.x now.
I've undone nenolod's QUIT+JOIN thing, don't like it. It's PART+JOIN like in 3.2.x. now.
|2013-08-10 04:49||Techman||New Issue|
|2013-08-11 03:32||Stealth||Note Added: 0017744|
|2013-08-11 03:32||Stealth||Assigned To||=> Stealth|
|2013-08-11 03:32||Stealth||Status||new => feedback|
|2013-08-11 04:09||Techman||Note Added: 0017746|
|2013-08-11 17:44||Stealth||Note Added: 0017747|
|2013-08-14 09:48||syzop||Note Added: 0017751|
|2013-08-25 01:23||katsklaw||Note Added: 0017759|
|2013-08-25 09:46||syzop||Note Added: 0017760|
|2014-03-14 01:14||peterkingalexander||Issue cloned: 0004286|
|2014-05-30 19:31||syzop||Note Added: 0018149|
|2014-05-30 19:31||syzop||Status||feedback => resolved|
|2014-05-30 19:31||syzop||Fixed in Version||=> 3.4-alpha1|
|2014-05-30 19:31||syzop||Resolution||open => fixed|
|2014-05-30 19:31||syzop||Assigned To||Stealth => syzop|