View Issue Details

IDProjectCategoryView StatusLast Update
0004241unrealircdpublic2014-05-30 19:36
ReportercardsAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAllOSOS Version
Product Version 
Target VersionFixed in Version3.4-alpha1 
Summary0004241: tsctl access levels
DescriptionAccording to TSCTL, a IRCop must be an admin or higher to utilize the tsctl command. However a Services Admin who is higher than an admin/Co-Admin does not have access to the command because they do not have the "A" flag by default (It must be added to the oper block). I suggest adding the admin (A) flag to Services admins by default (Much like NetAdmins). I'm sure this may also affect other parts of the IRCD.
TagsNo tags attached.
3rd party modules

Activities

bekarfel

2013-12-09 08:25

reporter   ~0017857

No. Adding features to make it easier to do something that is already easy to do is lazy. Also, this one will definitely break flexibility. Services Admins are intended to be Services Admins, not be Server Admins. So access to the tsctl is restricted from them. If you want an operator to have this ability, give it to him. Simple.

syzop

2014-01-12 10:34

administrator   ~0017874

oh. bleh.. *delete crap I just said*.. that was not what you were saying (at all)...

We can take a look at this during the audit of the current oper privilege system mentioned in 0004157... when we migrate to a new oper privilege system we can take this into account and see what's the best course of action.

syzop

2014-05-30 19:36

administrator   ~0018152

3.4 has can_tsctl:

changeset: 5310:28f9e289d4df
branch: unreal34
user: William Pitcock <nenolod@dereferenced.org>
date: Tue May 14 08:29:42 2013 +0000
summary: - Patch from FalconKirtaran to restrict /TSCTL OFFSET to can_tsctl permission (0002303)

Issue History

Date Modified Username Field Change
2013-10-15 04:54 cards New Issue
2013-12-09 08:25 bekarfel Note Added: 0017857
2014-01-12 10:30 syzop Status new => confirmed
2014-01-12 10:34 syzop Note Added: 0017874
2014-01-12 10:34 syzop Status confirmed => acknowledged
2014-03-14 01:14 peterkingalexander Issue cloned: 0004271
2014-05-30 19:36 syzop Note Added: 0018152
2014-05-30 19:36 syzop Status acknowledged => resolved
2014-05-30 19:36 syzop Fixed in Version => 3.4-alpha1
2014-05-30 19:36 syzop Resolution open => fixed
2014-05-30 19:36 syzop Assigned To => syzop