View Issue Details

IDProjectCategoryView StatusLast Update
0004247unrealinstallingpublic2016-09-30 15:30
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.10.2 
Target Version3.2.10.3Fixed in Version4.0.7 
Summary0004247: latest official c-ares does not compile with UnrealIRCd
Descriptionwith the official latest c-ares ./configure fails because we may supply C preprocessor flags in CFLAGS.
The error (from 0004244) is:
configure: CFLAGS error: CFLAGS may only be used to specify C compiler flags, not include directories. Use CPPFLAGS for: -I/usr/local/include

Similarly it may complain about other flags as well, see cares/m4/xc-val-flgs.m4

Our (Unreal) configure may add an -I to certain directories when compiling with things like openssl (and zlib?). The code is there to catch common installations of openssl/zlib on systems that don't have these in the default search paths, hence we add them in configure.

Similarly, we use curl-config to grab cflags and such to add these...
$ ~/curl/bin/curl-config --cflags
-I/home/syzop/curl/include
which is funny because that would conflict with c-ares ;)

Anyway, maybe we can just avoid those problems and run the c-ares configure script before setting any CFLAGS/etc?

And(/or) update our Makefile and configure scripts to also support the use of CPPFLAGS.

Additional InformationJust so you know: in 3.2.10.2 with latest c-ares I simply ripped out those CPPFLAGS checks and recreated the c-ares.tar.gz.
TagsNo tags attached.
3rd party modules

Activities

syzop

2015-07-10 11:14

administrator   ~0018469

Could you take a look at this, Travis?

syzop

2016-09-30 15:30

administrator   ~0019434

Fixed in 4.0.7.

Issue History

Date Modified Username Field Change
2013-12-04 16:52 syzop New Issue
2013-12-04 16:52 syzop Assigned To => ohnobinki
2013-12-04 16:52 syzop Status new => assigned
2013-12-04 16:54 syzop Description Updated View Revisions
2014-03-14 01:14 peterkingalexander Issue cloned: 0004276
2014-07-05 14:11 syzop Assigned To ohnobinki =>
2014-07-05 14:11 syzop Status assigned => acknowledged
2015-07-10 11:13 syzop Assigned To => tmcarthur
2015-07-10 11:13 syzop Status acknowledged => assigned
2015-07-10 11:14 syzop Note Added: 0018469
2016-09-30 15:30 syzop Note Added: 0019434
2016-09-30 15:30 syzop Status assigned => resolved
2016-09-30 15:30 syzop Fixed in Version => 4.0.7
2016-09-30 15:30 syzop Resolution open => fixed
2016-09-30 15:30 syzop Assigned To tmcarthur => syzop