View Issue Details

IDProjectCategoryView StatusLast Update
0004272unrealircdpublic2014-03-14 01:14
ReporterpeterkingalexanderAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSMac OS XOS Version10.9 (13A603)
Product Version3.2.10.2 
Target VersionFixed in Version3.2.10.3 
Summary0004272: Inlines break OS X build
DescriptionI'm guessing the compiler or linker is exoecting C99, or something else that isn't GNU89.
Steps To Reproduce./Config
make
# setup unrealircd.conf
unreal start
TagsNo tags attached.
3rd party modules

Activities

JustinTArthur

2013-12-17 08:46

reporter   ~0017954

Example ouput of running ./unreal start:

* Loading IRCd configuration ..
* unrealircd.conf:36: loadmodule src/modules/commands.so: failed to load: dlopen(tmp/E3E72481.commands.so, 2): Symbol not found: _fast_badword_match
[error] IRCd configuration failed to load
Possible error encountered (IRCd seemingly not started)

2013-12-17 08:48

 

issue_4251-add_gnu89_to_darwin_build.patch (773 bytes)

JustinTArthur

2013-12-17 08:52

reporter   ~0017955

Uploaded a fix that forces GNU89 interpretation. Similar to the patch for 0004239 (BSD version of same issue), except doesn't add the export-dynamic option; that option didn't seem needed in this case.

syzop

2013-12-17 17:53

administrator   ~0017956

Ok, thanks, I'll take a look at both.

If this fixes all OS X problems (it does, right?) then I'm seriously considering releasing 3.2.10.3 since we want OS X to work out of the box.

JustinTArthur

2013-12-17 19:24

reporter   ~0017957

I can confirm that with a clean clone with the above patch applied, I can ./Config, compile, and run ircd on the latest from Apple, OS X 10.9.1 (13B42).

My system has the following:
Developer toolchain from XCode 5.0.2
Out of the box libcurl from XCode 5.0.2 (for remote includes support)
c-ares lib from Homebrew (for remote includes support)
Passed "--with-system-cares" to ./configure

syzop

2014-01-12 10:21

administrator   ~0017958

Fixed in http://hg.unrealircd.com/hg/unreal/rev/05dcf4fd18ab
Changelog:
Fix compile problem on OS X 10.9, reported and patch provided by JustinTArthur (0004251).

Thanks!

Issue History

Date Modified Username Field Change
2014-03-14 01:14 peterkingalexander New Issue
2014-03-14 01:14 peterkingalexander Issue generated from: 0004251