View Issue Details

IDProjectCategoryView StatusLast Update
0004293unrealircdpublic2014-03-14 01:14
ReporterpeterkingalexanderAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformALLOSTested on *NIXOS VersionALL
Product Version3.2.4 
Target VersionFixed in Version3.2.10.2 
Summary0004293: Odd link binding behavior
DescriptionOk, this is just odd. If your link::bind-ip is set to "*" then unreal will bind to the ip of your last listen line.
So, basically if you have:
listen 1.2.3.4:6667;
listen 1.2.3.5:6667;
listen 127.0.0.1:8000;

and a link block like
link somehost
{
  hostname 1.2.3.6;
  bind-ip *;
[etc]

then your linkblock will fail, with a weird error "invalid argument".

interim solution:
- specify the ip to bind to (eg: 1.2.3.4) in link::bind-ip
- change the order of the listen lines

Suggested behavior:
Do not bind at all if bind-ip is set to "*". But do note that some people might depend on it and will have to update their link::bind-ip's which previously was on "*"... bleh...
TagsNo tags attached.
3rd party modules

Activities

Bock

2007-06-22 12:57

reporter   ~0018057

ooooooooo... So hard to reproduce why I get "invalid argument" on /connect server ... Only on one server in my network.
+1 - this is a bug, I'm going to fix in my server. :]

Bock

2007-07-17 17:13

reporter   ~0018058

+1 for now - remake config file, restart ircd - no error "invalid argument" and remote connects works fine.
3.2.7 for now.

katsklaw

2013-07-25 02:05

reporter   ~0018059

uhm, yeah +1 bug. This also happens if your last listen block is IPv6.

syzop

2013-08-07 09:02

administrator   ~0018060

Oh, this was resolved a few months ago, but this bug wasnt closed:

[2013-05-10] Bram Matthys <syzop@vulnscan.org> (a033da33a60e):
- Fix strange issue where linking didn't work because UnrealIRCd would
bind to (for example) the loopback interface before connecting to the
remote server.
In addition to that, we now don't bind() at all when bind-ip is not
present or is set to "*".

katsklaw: if there's still any issue with current devel repository, let us know!

Issue History

Date Modified Username Field Change
2014-03-14 01:14 peterkingalexander New Issue
2014-03-14 01:14 peterkingalexander Issue generated from: 0002799