View Issue Details

IDProjectCategoryView StatusLast Update
0004323unrealircdpublic2019-10-14 15:21
ReporterwestorAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.2.4.1 
Summary0004323: m_invite_delay
DescriptionIs there any way to make the /invite command to have a custom delay and the user can use the /invite command again after X seconds and an configuration option in the config file to change it.
TagsNo tags attached.
3rd party modules

Activities

tmcarthur

2014-08-18 04:55

reporter   ~0018220

Are you thinking that this would also invalidate previous invite? In other words, would this mean "invites expire after X minutes"? Also are you thinking on channel level, or network wide (I would worry about desync if it was server based, which is another reason I'm a little reluctant on this one).

katsklaw

2014-09-15 06:46

reporter   ~0018242

Last edited: 2014-09-15 06:49

View 2 revisions

My impression is the OP wants something more like an /invite throttle. However, I fail to see why this would be useful. If an user is invited and does not join the channel nothing else happens. Additionally, if the user is invited again, nothing changes and resource usage is unaffected making it to where the command cannot be abused.

At worst, the inviter will fill their recvQ and the ircd will /kill them which will be less overhead than us keeping track of invite timers for every channel that uses invites. This scenario is not really possible without a script so if it did happen, the user would deserve the /kill.

Just Sayin

syzop

2019-10-14 15:21

administrator   ~0020972

Going through old bug reports... We now have set::anti-flood::invite-flood since 4.2.4(.1?) which is basically exactly what this request was :)
Also, we have set::restrict-commands by which you can disable the /INVITE command the first 60 seconds (for example).

Issue History

Date Modified Username Field Change
2014-08-05 16:14 westor New Issue
2014-08-18 04:55 tmcarthur Note Added: 0018220
2014-09-15 06:46 katsklaw Note Added: 0018242
2014-09-15 06:49 katsklaw Note Edited: 0018242 View Revisions
2019-10-14 15:21 syzop Assigned To => syzop
2019-10-14 15:21 syzop Status new => resolved
2019-10-14 15:21 syzop Resolution open => fixed
2019-10-14 15:21 syzop Fixed in Version => 4.2.4.1
2019-10-14 15:21 syzop Note Added: 0020972