View Issue Details

IDProjectCategoryView StatusLast Update
0004339unrealircdpublic2015-06-20 15:17
ReporterkatsklawAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86_64OSDebianOS Version6/7
Product Version3.4-alpha1 
Target VersionFixed in Version3.4-alpha4 
Summary0004339: modules.conf needs reworked
Descriptionmodules.conf has RFC required modules, like join/pingpong/quit/nick, intermixed with optional modules. This is bad juju. Required modules should be separated into their own section with a note saying they are required or the world will break. As-is, the /nick command is given the same importance as adminchat.

/* Required by RFC commands (do NOT uncomment unless you like breaking stuff) */
mod
mod

/* begin optional modules that may be needed, like chghost for services */
mod
mod

/* begin optional, but highly recommended modules */
mod
mod

/* begin optional modules that some people like but you can live without */
mod
mod

etc ..
Additional Information1 line module descriptions are also nice because not everyone knows what m_sdesc is.
TagsNo tags attached.
3rd party modules

Activities

katsklaw

2014-12-28 05:55

reporter  

diff.patch (12,388 bytes)

katsklaw

2014-12-28 05:55

reporter   ~0018277

can haz patch.

syzop

2015-06-20 15:17

administrator   ~0018408

Done.

And I see I could have saved myself some hassle as katsklaw already did nearly the same ;D

Issue History

Date Modified Username Field Change
2014-11-19 06:18 katsklaw New Issue
2014-11-26 08:23 tmcarthur Assigned To => tmcarthur
2014-11-26 08:23 tmcarthur Status new => assigned
2014-12-28 05:55 katsklaw File Added: diff.patch
2014-12-28 05:55 katsklaw Note Added: 0018277
2015-06-20 15:17 syzop Note Added: 0018408
2015-06-20 15:17 syzop Status assigned => resolved
2015-06-20 15:17 syzop Fixed in Version => 3.4-alpha4
2015-06-20 15:17 syzop Resolution open => fixed
2015-06-20 15:17 syzop Assigned To tmcarthur => syzop