View Issue Details

IDProjectCategoryView StatusLast Update
0004365unrealircdpublic2015-06-22 19:35
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.4-alpha3 
Target VersionFixed in Version3.4-alpha4 
Summary0004365: halfops privileges
DescriptionLook at halfop privileges.

The attached PNG looked at the situation with a proposal from me from August 2003... hmm... little while ago.
Additional InformationSorry for the PNG. Didn't want to type it over.
TagsNo tags attached.
3rd party modules

Activities

syzop

2015-06-17 20:07

administrator  

unreal_halfops.png (13,644 bytes)

syzop

2015-06-17 20:08

administrator   ~0018406

confirmed as in needs-to-be-changed. the unreal_halfops.png is just a start. will have to look it all over again @ current

syzop

2015-06-22 19:34

administrator   ~0018414

Last edited: 2015-06-22 19:35

View 2 revisions

Done. Used the table from 2003.

I noticed we have a 'no notice' mode since then (debatable, not included) and also +j. I don't think we should halfops change +j since we don't allow them to change +f either.


https://github.com/unrealircd/unrealircd/commit/efc63dff8127f00aedb4e143796e15dd3bc5b0ea
**
Permit halfops to set more modes than before. The idea is halfops should be able to help out in case of a flood but not be able to change any 'policy decission' modes such as +G, +S, +c, +s.

The following modes are now permitted to halfops: +iklmntMKNCR (was: +ikmnt)
**
EDIT: oh for accuracy, +beI is also permitted (no change).

Issue History

Date Modified Username Field Change
2015-06-17 20:07 syzop New Issue
2015-06-17 20:07 syzop File Added: unreal_halfops.png
2015-06-17 20:08 syzop Note Added: 0018406
2015-06-17 20:08 syzop Status new => confirmed
2015-06-22 19:34 syzop Note Added: 0018414
2015-06-22 19:34 syzop Status confirmed => resolved
2015-06-22 19:34 syzop Fixed in Version => 3.4-alpha4
2015-06-22 19:34 syzop Resolution open => fixed
2015-06-22 19:34 syzop Assigned To => syzop
2015-06-22 19:35 syzop Note Edited: 0018414 View Revisions