View Issue Details

IDProjectCategoryView StatusLast Update
0004375unrealircdpublic2015-07-18 22:07
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.4-beta1 
Target Version3.4-beta2Fixed in Version3.4-beta2 
Summary0004375: linking with ssl fp broken
DescriptionThis commit https://github.com/unrealircd/unrealircd/commit/4ca497ffef6d884f407be37fefe5179a5f95cd51 broke server linking with ssl client certificate fingerprints

because the module certfp sets it on user connect, doesn't happen on outgoing link or incoming link. needs to hook in at a different place (no, not hooktype_server).

pretty silly as we have a linking tutorial that uses exactly this.
TagsNo tags attached.
3rd party modules

Issue History

Date Modified Username Field Change
2015-07-17 20:49 syzop New Issue
2015-07-18 22:07 syzop Note Added: 0018514
2015-07-18 22:07 syzop Status new => resolved
2015-07-18 22:07 syzop Fixed in Version => 3.4-beta2
2015-07-18 22:07 syzop Resolution open => fixed
2015-07-18 22:07 syzop Assigned To => syzop