View Issue Details

IDProjectCategoryView StatusLast Update
0004425unrealdocumentationpublic2015-10-14 22:02
Reportertester1001Assigned Tosyzop 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSRasbianOS Version4.1.7
Product Version4.0.0-rc1 
Target VersionFixed in Version4.0.0-rc2 
Summary0004425: Channel Mode +A unavailable
DescriptionUnable to set Channel mode +A for Administrators only
Server reports "A is unknown mode char to me"
Steps To ReproduceI setup an operclass with default of netadmin-with-override. Logged onto server, opered, confirmed netadmin-with-override status. Created a channel, tried to set +A channel mode. Server returns

A is unknown mode char to me
TagsNo tags attached.
3rd party modulesnone

Activities

blank

2015-10-14 14:14

reporter   ~0018740

Last edited: 2015-10-14 20:59

View 4 revisions

@tester1001

This is not a bug.

+A does not exist in Unreal4 as per https://www.unrealircd.org/docs/Channel_Modes.

You will need to write a third-party module for it.

tester1001

2015-10-14 20:05

reporter   ~0018741

I miss understood. The command /helpop ?chmodes
still lists A as a channel mode

syzop

2015-10-14 22:02

administrator   ~0018742

I've adjusted help.conf. Thanks for the report :)

[unreal40 7637517] In UnrealIRCd 4 channel mode j & A no longer exist, same for user modes O, a, A, N, C. Also oper flags no longer exist.
https://github.com/unrealircd/unrealircd/commit/7637517da28ae268f3c9515b4d2e3a98af5ea423

Issue History

Date Modified Username Field Change
2015-10-14 03:33 tester1001 New Issue
2015-10-14 14:14 blank Note Added: 0018740
2015-10-14 14:15 blank Note Edited: 0018740 View Revisions
2015-10-14 14:16 blank Note Edited: 0018740 View Revisions
2015-10-14 20:05 tester1001 Note Added: 0018741
2015-10-14 20:59 blank Note Edited: 0018740 View Revisions
2015-10-14 22:01 syzop Category ircd => documentation
2015-10-14 22:02 syzop Note Added: 0018742
2015-10-14 22:02 syzop Status new => resolved
2015-10-14 22:02 syzop Fixed in Version => 4.0.0-rc2
2015-10-14 22:02 syzop Resolution open => fixed
2015-10-14 22:02 syzop Assigned To => syzop