View Issue Details

IDProjectCategoryView StatusLast Update
0004440unrealircdpublic2015-10-30 09:27
ReporterManuelAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.0.0-rc2 
Target VersionFixed in Version4.0.0-rc3 
Summary0004440: motd and rules Bug
DescriptionI found a mistake,

[27.10.15|22:50:40] (!Manuel) [Di 27.10|22:43:47] error: /home/ircd/unrealircd/conf/unrealircd.conf:50: tld::motd: ircd.motd: No such file or directory
[27.10.15|22:50:40] (!Manuel) [Di 27.10|22:43:47] error: /home/ircd/unrealircd/conf/unrealircd.conf:51: tld::rules: ircd.rules: No such file or directory
Additional Informationroot@Server1 ~ # locate ircd.motd
/home/ircd/ircd.motd
/home/ircd/Unreal3.2.10.4/ircd.motd
/home/ircd/unrealircd/ircd.motd
/home/ircd/unrealircd/ircd.motd.de
/home/ircd/unrealircd/bin/ircd.motd
/home/ircd/unrealircd/conf/ircd.motd <-----------
root@Server1 ~ # locate ircd.rules
/home/ircd/ircd.rules
/home/ircd/Unreal3.2.10.4/ircd.rules
/home/ircd/unrealircd/ircd.rules
/home/ircd/unrealircd/ircd.rules.de
/home/ircd/unrealircd/bin/ircd.rules
/home/ircd/unrealircd/conf/ircd.rules <-----------
root@Server1 ~ #
TagsNo tags attached.
3rd party modules

Activities

blank

2015-10-28 21:40

reporter   ~0018814

Last edited: 2015-10-28 21:41

View 2 revisions

@Manuel without checking the source I assume that it is checking the path from the binary (/home/unrealircd/unrealircd), so it is looking for /home/unrealircd/ircd.motd and /home/unrealircd/ircd.rules. Have you tried setting them to conf/ircd.motd and conf/ircd.rules (or just moving both to /home/unrealircd/ircd.motd and /home/unrealircd/ircd.rules, since these aren't configuration files so don't belong in conf/ anyway)?

Manuel

2015-10-28 22:21

reporter   ~0018816

Last edited: 2015-10-28 22:29

View 4 revisions

I repeat it once again, where Unrealircd is installed with me; It is compiled with me in the Shell account ircd (/home/ircd) in the list "unrealircd"

root@Server1 ~ # locate ircd.motd
/home/ircd/ircd.motd
/home/ircd/Unreal3.2.10.4/ircd.motd
/home/ircd/unrealircd/ircd.motd
/home/ircd/unrealircd/ircd.motd.de
/home/ircd/unrealircd/bin/ircd.motd
"/home/ircd/unrealircd/conf/ircd.motd <-----------"
root@Server1 ~ # locate ircd.rules
/home/ircd/ircd.rules
/home/ircd/Unreal3.2.10.4/ircd.rules
/home/ircd/unrealircd/ircd.rules
/home/ircd/unrealircd/ircd.rules.de
/home/ircd/unrealircd/bin/ircd.rules
"/home/ircd/unrealircd/conf/ircd.rules <-----------"
root@Server1 ~ #

Labelled files are not found, what the Deamon must find since this; Is and this one has left availably a bow relaxedly must be.

To say more clearly once again: "ircd" is a Shell account, what one also can see.

blank

2015-10-28 22:27

reporter   ~0018817

Last edited: 2015-10-28 22:28

View 2 revisions

I cannot reproduce this.

echo 'test' > /home/irc/unrealircd/conf/ircd.motd
/home/irc/unrealircd/unrealircd rehash

/motd

TKCHA12. Message of the Day -
28/10/2015 21:25
test
End of /MOTD command.

Manuel

2015-10-28 22:45

reporter   ~0018818

Last edited: 2015-10-28 22:46

View 2 revisions

ircd@server1:~/unrealircd$ echo 'test' > /home/ircd/unrealircd/conf/ircd.motd
ircd@server1:~/unrealircd$ echo 'test' > /home/ircd/unrealircd/conf/ircd.rules
ircd@server1:~/unrealircd$ ./unrealircd start
Starting UnrealIRCd
 _ _ _ ___________ _____ _
| | | | | |_ _| ___ \/ __ \ | |
| | | |_ __ _ __ ___ __ _| | | | | |_/ /| / \/ __| |
| | | | '_ \| '__/ _ \/ _` | | | | | / | | / _` |
| |_| | | | | | | __/ (_| | |_| |_| |\ \ | \__/\ (_| |
 \___/|_| |_|_| \___|\__,_|_|\___/\_| \_| \____/\__,_|
                           v4.0.0-rc2

  using TRE 0.8.0 (BSD)
  using OpenSSL 1.0.1k 8 Jan 2015

Loading IRCd configuration..
config error: /home/ircd/unrealircd/conf/unrealircd.conf:50: tld::motd: ircd.motd: No such file or directory
config error: /home/ircd/unrealircd/conf/unrealircd.conf:51: tld::rules: ircd.rules: No such file or directory
config error: 2 errors encountered
config error: IRCd configuration failed to pass testing
=====================================================
UnrealIRCd failed to start. Check above for possible errors.
If you don't understand the problem, then have a look at our:
* FAQ (Frequently Asked Questions): https://www.unrealircd.org/docs/FAQ
* Documentation: https://www.unrealircd.org/docs/
=====================================================
ircd@server1:~/unrealircd$

blank

2015-10-29 11:29

reporter   ~0018819

Last edited: 2015-10-29 11:33

View 3 revisions

Just remove lines 50 and 51 or change them to absolute paths '/home/ircd/unrealircd/conf/ircd.motd' and '/home/ircd/unrealircd/conf/ircd.rules'.

I don't have those set in our .conf and it still works. You only need to use a TLD block if you want more advanced configuration, different motd for different country etc.

Manuel

2015-10-29 12:59

reporter   ~0018820

The bug still remains

blank

2015-10-29 14:13

reporter   ~0018821

No issue here

echo 'test' > /home/irc/unrealircd/conf/ircd.motd
/home/irc/unrealircd/unrealircd rehash

/motd

TKCHA12. Message of the Day -
28/10/2015 21:25
test
End of /MOTD command.



Bug cannot be reproduced.

Manuel

2015-10-29 15:51

reporter   ~0018822

To bug is now time, the need to test yourself and go on seeking the developer

syzop

2015-10-29 18:01

administrator   ~0018825

I see. It uses the correct file location for the default ircd.motd, but in tld { } blocks it doesn't work. I'll fix it, thanks.

syzop

2015-10-30 09:26

administrator   ~0018833

Fixed. Thanks Manuel.

[unreal40 c06e3a7] Files in the tld { } block were being loaded from the wrong location, resulting in errors/confusion. Reported by Manuel (0004440).
https://github.com/unrealircd/unrealircd/commit/c06e3a7ef643f9ced1d3a22c9c3975167fa58874

Issue History

Date Modified Username Field Change
2015-10-28 18:09 Manuel New Issue
2015-10-28 21:40 blank Note Added: 0018814
2015-10-28 21:41 blank Note Edited: 0018814 View Revisions
2015-10-28 22:21 Manuel Note Added: 0018816
2015-10-28 22:24 Manuel Note Edited: 0018816 View Revisions
2015-10-28 22:26 Manuel Note Edited: 0018816 View Revisions
2015-10-28 22:27 blank Note Added: 0018817
2015-10-28 22:28 blank Note Edited: 0018817 View Revisions
2015-10-28 22:29 Manuel Note Edited: 0018816 View Revisions
2015-10-28 22:45 Manuel Note Added: 0018818
2015-10-28 22:46 Manuel Note Edited: 0018818 View Revisions
2015-10-29 11:29 blank Note Added: 0018819
2015-10-29 11:30 blank Note Edited: 0018819 View Revisions
2015-10-29 11:33 blank Note Edited: 0018819 View Revisions
2015-10-29 12:59 Manuel Note Added: 0018820
2015-10-29 14:13 blank Note Added: 0018821
2015-10-29 15:51 Manuel Note Added: 0018822
2015-10-29 18:01 syzop Note Added: 0018825
2015-10-29 18:01 syzop Assigned To => syzop
2015-10-29 18:01 syzop Status new => acknowledged
2015-10-30 09:26 syzop Note Added: 0018833
2015-10-30 09:26 syzop Status acknowledged => resolved
2015-10-30 09:26 syzop Fixed in Version => 4.0.0-rc3
2015-10-30 09:26 syzop Resolution open => fixed