View Issue Details

IDProjectCategoryView StatusLast Update
0004469unrealircdpublic2015-12-09 17:46
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.0.0-rc3 
Target VersionFixed in Version4.0.0-rc5 
Summary0004469: Flood: Cannot accept connections: Operation not supported
Description09:45 - reporter- has anyone else ever received 'Cannot accept connections :Operation not supported
09:45 - reporter- on 4?
09:54 -Syzop[AWAY]- no. but that isn't good :D
09:59 - reporter- Syzop[AWAY]: could it be something to do with blacklist module?
10:00 - reporter- I only log 'errors', and ircd.log is just errors about blacklist and errors that I posted above
               'Cannot accept connections'
..
10:01 - reporter- but that notice was flooding, literally 1000's a minute :P
10:01 -Syzop[AWAY]- ic. was? not anymore?
10:24 - reporter- I restarted
10:56 - reporter- Syzop[AWAY]: should i put something on the bug tracker or not ?
10:56 - reporter- all i have is that 1 log file tho
10:58 - reporter- [Mon Nov 23 09:56:59 2015] - Blacklist Requests for x.x.x.x canceled ()
10:58 - reporter- lots of these too
10:58 - reporter- are these 'errors'?
..
09:50 -reporter- jeeees, just seen my usage on that 1 server
09:50 -reporter- 100000x cpu past 4 hrs compared to usual
Additional Information(guess -rc3 but not sure)
TagsNo tags attached.
3rd party modules

Activities

syzop

2015-11-25 15:19

administrator   ~0018880

This is caused by an accept() failure.
I don't think accept() can return "Operation not supported" on a listener TCP socket. If that assumption is true then it means it is (no longer) a TCP listener socket.. perhaps the socket has been closed & overwritten by some other socket somehow (eg: closing wrong fd somewhere).
The blacklist module does nothing with FD's. It does use c-ares extensively though, which does open & close FD's.

syzop

2015-11-25 15:26

administrator   ~0018881

I've been hammering my server with clones (about 300-500 clones per second), with a few of them on a local blacklist. Disconnecting, connecting, constantly.
No issues.

(Tried also both with and without identd-check and with cached and uncached IP's)

syzop

2015-12-09 17:46

administrator   ~0018905

Not resolved, but a workaround has been added:
[unreal40 f6a58b6] Added workaround for "Cannot accept connections: Operation not supported" problem (0004469).

https://github.com/unrealircd/unrealircd/commit/f6a58b60af9220fa23e7361328f99c7902e2fc06

UnrealIRCd will now close the listener and re-create it.
(This assumes the problem is at an UnrealIRCd level)

Issue History

Date Modified Username Field Change
2015-11-25 15:11 syzop New Issue
2015-11-25 15:15 syzop Description Updated View Revisions
2015-11-25 15:15 syzop Additional Information Updated View Revisions
2015-11-25 15:19 syzop Note Added: 0018880
2015-11-25 15:26 syzop Note Added: 0018881
2015-12-09 17:43 syzop Description Updated View Revisions
2015-12-09 17:46 syzop Note Added: 0018905
2015-12-09 17:46 syzop Status new => resolved
2015-12-09 17:46 syzop Fixed in Version => 4.0.0-rc5
2015-12-09 17:46 syzop Resolution open => fixed
2015-12-09 17:46 syzop Assigned To => syzop