View Issue Details

IDProjectCategoryView StatusLast Update
0004482unrealdocumentationpublic2016-01-11 18:17
ReporterGLololAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS VersionStretch/sid
Product Version4.0.0-rc4 
Target VersionFixed in Version4.0.1 
Summary0004482: /squit server.* does not work
DescriptionContrary to /helpop SQUIT, using wildcards in /SQUIT does not work with unreal 4.0:

* Syntax: SQUIT <server>
* Example: SQUIT leaf.*

Instead, something like "/squit services*" will cause an error:
* services* :No such server

/map looks like (for reference, this):
* unreal.midnight.vpn (1) 001
* |-pylink.local (1) 38Q
* | |-ovd.relay (4) 902
* | |-chary.relay (1) 901
* | `-devel.relay (1) 900
* `-services.int (12) 00A
Steps To Reproduce- Link a server

- Attempt to /SQUIT it by matching its name in a glob.
TagsNo tags attached.
3rd party modules

Activities

syzop

2016-01-11 18:17

administrator   ~0019040

Earlier, when fixing nenofucks code, I figured I'd remove the wildcard thing so make us stop 'guessing'. I don't like guessing, especially if it may result in the wrong server splitting or connecting ;)

So I've updated the documentation:
[unreal40 8aa655d] Remove server wildcard examples from help.conf, reported by GLolol (0004482).
https://github.com/unrealircd/unrealircd/commit/8aa655df3a56cb7a85982d31849a526ff343d640

Thanks.

Issue History

Date Modified Username Field Change
2015-12-07 02:59 GLolol New Issue
2015-12-10 21:08 syzop Category ircd => documentation
2016-01-11 18:17 syzop Note Added: 0019040
2016-01-11 18:17 syzop Status new => resolved
2016-01-11 18:17 syzop Fixed in Version => 4.0.1
2016-01-11 18:17 syzop Resolution open => fixed
2016-01-11 18:17 syzop Assigned To => syzop