View Issue Details

IDProjectCategoryView StatusLast Update
0004501unrealmodule apipublic2022-06-19 20:22
Reporteruser7695Assigned Tosyzop  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version4.0.0-rc6 
Fixed in Version6.0.5 
Summary0004501: An XML-RPC interface.
DescriptionI think an XML-RPC interface with Unreal would be nice.

It would allow for (correctly authenticated) opers to with the `can_xmlrpc` flag to perform operations remotely (from a web portal or such things).

Things like:
add/delete/edit opers,
add/delete/edit link blocks,
add/delete/edit listen blocks,
rehash Unreal,
add/delete/edit ircd.rules, ircd.motd, ircd.smotd etc

Obviously it's too late to add it to the 4.0 branch but perhaps it could be included in the 4.1 branch?
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0003140 assignedsyzop RPC communication 
related to 0000536 closedsyzop Config changes through WEB 

Activities

syzop

2022-06-19 20:22

administrator   ~0022564

Foundation for this has been added today. Going to use 0003140 to track this.

Issue History

Date Modified Username Field Change
2015-12-23 11:05 user7695 New Issue
2017-01-06 15:48 syzop Category module => module api
2022-06-19 20:20 syzop Relationship added related to 0003140
2022-06-19 20:21 syzop Relationship added related to 0000536
2022-06-19 20:22 syzop Assigned To => syzop
2022-06-19 20:22 syzop Status new => closed
2022-06-19 20:22 syzop Resolution open => duplicate
2022-06-19 20:22 syzop Fixed in Version => 6.0.5
2022-06-19 20:22 syzop Note Added: 0022564
2022-06-19 20:22 syzop Relationship replaced duplicate of 0003140