View Issue Details

IDProjectCategoryView StatusLast Update
0004507unrealmodule apipublic2015-12-28 19:11
ReporterblankAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.0.0 
Target VersionFixed in Version4.0.1 
Summary0004507: blacklist module enhancements
Descriptionreplace %ip in blacklist reason with the actual IP address

use case:

reason "You have a host listed in someRBL. Please visit http://someRBL.com/lookup?ip=%ip for more information.";
TagsNo tags attached.
3rd party modules

Activities

syzop

2015-12-28 19:10

administrator   ~0018975

Thanks, added :)

Online documentation has been updated as well. We now have %ip and %server. We don't expose %nick as there may not be a nickname (this is often the case) because the check is so fast, similarly we don't provide %host either since the host may not be looked up yet (again because we act so fast). Just in case you wonder.

[unreal40 34b9797] Add buildvarstring() function and make blacklist module support %ip and %server variables in reason field. Suggested by blank (0004507).
https://github.com/unrealircd/unrealircd/commit/34b9797ffcd836014cc5c91507bada7acab4cf90

Issue History

Date Modified Username Field Change
2015-12-26 00:18 blank New Issue
2015-12-26 10:28 syzop Assigned To => syzop
2015-12-26 10:28 syzop Status new => acknowledged
2015-12-26 10:28 syzop Severity minor => feature
2015-12-26 10:28 syzop Product Version => 4.0.0
2015-12-28 19:10 syzop Note Added: 0018975
2015-12-28 19:10 syzop Status acknowledged => resolved
2015-12-28 19:10 syzop Fixed in Version => 4.0.1
2015-12-28 19:10 syzop Resolution open => fixed
2017-01-06 15:48 syzop Category module => module api