View Issue Details

IDProjectCategoryView StatusLast Update
0004520unrealircdpublic2015-12-29 11:33
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.0.0 
Target VersionFixed in Version4.0.1 
Summary0004520: ./unrealircd [stop|rehash] not working - something with pid file I guess
Description22:59 <+Hawk> ~/Unreal4 $ ./unrealircd rehash
22:59 <+Hawk> Rehashing UnrealIRCd
22:59 <+Hawk> ERROR: UnrealIRCd is not running
22:59 <+Hawk> is what i get, same when using 'stop'

and

02:45 <+SmashingX> because in my server I run ./unrealircd rehash
02:46 <+SmashingX> and I get this: ERROR: UnrealIRCd is not running
02:46 <+SmashingX> and it's obviously running
02:46 <+SmashingX> otherwise how am I connected to the server
... then regarding unrealircd.pid....
02:50 <+SmashingX> I don't have that file
02:50 <+SmashingX> inside of the data directory I only have ircd.tune

TagsNo tags attached.
3rd party modules

Activities

syzop

2015-12-29 11:05

administrator   ~0018978

Last edited: 2015-12-29 11:06

View 2 revisions

Since multiple people have this problem there must be something. I can't reproduce it though... even if I './unrealircd start' multiple times nor when I run the ./unrealircd script not from ~/unrealircd, etc...

It must be something simple, but what..

blank

2015-12-29 11:08

reporter   ~0018980

I can't reproduce this

syzop

2015-12-29 11:12

administrator   ~0018981

*** paste from Hawk ***

./unrealircd start
Starting UnrealIRCd
 _ _ _ ___________ _____ _
| | | | | |_ _| ___ \/ __ \ | |
| | | |_ __ _ __ ___ __ _| | | | | |_/ /| / \/ __| |
| | | | '_ \| '__/ _ \/ _` | | | | | / | | / _` |
| |_| | | | | | | __/ (_| | |_| |_| |\ \ | \__/\ (_| |
 \___/|_| |_|_| \___|\__,_|_|\___/\_| \_| \____/\__,_|
                           v4.0.0

  using TRE 0.8.0 (BSD)
  using OpenSSL 1.0.1e 11 Feb 2013

Loading IRCd configuration..
^[[Configuration loaded without any problems.
Loading tunefile..
Initializing SSL..
Dynamic configuration initialized.. booting IRCd.
UnrealIRCd is now listening on the following addresses/ports:
IPv4: *:6668
IPv6: *:6668
UnrealIRCd started.
pi@raspberrypi ~/Unreal4 $ ./unrealircd stop
Stopping UnrealIRCd
ERROR: UnrealIRCd is not running

blank

2015-12-29 11:17

reporter   ~0018982

Last edited: 2015-12-29 11:19

View 2 revisions

I can't check code easily right now, but is the PID path hard coded?

I install to the default `unrealircd` directory where as that seems to be using a custom `Unreal4` directory.

Just a thought.

syzop

2015-12-29 11:22

administrator   ~0018983

Ah. Found it, the PIDFILE is always $HOME/unrealircd/data/unrealircd.pid
So if you install to a different directory things go wrong.

blank

2015-12-29 11:22

reporter   ~0018984

;-)

syzop

2015-12-29 11:32

administrator   ~0018985

[unreal40 3ec4cfb] *NIX: Fix ./unrealircd [rehash|stop|restart] not working if you install to somewhere other than ~/unrealircd/, it always said "UnrealIRCd is not running". Reported by Hawk and SmashingX (0004520).
https://github.com/unrealircd/unrealircd/commit/3ec4cfb2b8b098d7a5eb85b6b55b8543b5ce27a3

Oh and thanks blank for trying to reproduce :)

Issue History

Date Modified Username Field Change
2015-12-29 11:03 syzop New Issue
2015-12-29 11:04 syzop Description Updated View Revisions
2015-12-29 11:05 syzop Note Added: 0018978
2015-12-29 11:05 syzop Assigned To => syzop
2015-12-29 11:05 syzop Status new => acknowledged
2015-12-29 11:06 syzop Note Edited: 0018978 View Revisions
2015-12-29 11:08 blank Note Added: 0018980
2015-12-29 11:12 syzop Note Added: 0018981
2015-12-29 11:17 blank Note Added: 0018982
2015-12-29 11:19 blank Note Edited: 0018982 View Revisions
2015-12-29 11:22 syzop Note Added: 0018983
2015-12-29 11:22 blank Note Added: 0018984
2015-12-29 11:32 syzop Note Added: 0018985
2015-12-29 11:32 syzop Status acknowledged => resolved
2015-12-29 11:32 syzop Fixed in Version => 4.0.1
2015-12-29 11:32 syzop Resolution open => fixed