View Issue Details

IDProjectCategoryView StatusLast Update
0004533unrealircdpublic2016-01-03 15:40
ReporterZoddoAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUNIXOSDebian 7OS VersionUnrealIRCd 4.0.0
Product Version4.0.0 
Target VersionFixed in Version4.0.1 
Summary0004533: Incomplete MD command for certfp
DescriptionWhen the IRCd introduce the user on the network, the MD command (for the certificate fingerprint) is incomplete.

:server.name MD client certfp :abcdefghijklmnopqrstuvwxyz......
:001 UID Zoddo 0 1451769921 ~Zoddo 192.168.0.200 001M1DV04 0 +wz 192.168.0.200 192.168.0.200 wKgAyA== :Zoddo

As you see, the nick/UID is missing (note the 2 spaces between "client" & "certfp")

Because the MD command is sent before the UID command, the IRCd seems to don't have generated the UID yet.
Tagscertfp
3rd party modules

Activities

syzop

2016-01-03 10:13

administrator   ~0019010

yup, can reproduce. something with sequencing.

syzop

2016-01-03 15:40

administrator   ~0019011

And fixed: https://github.com/unrealircd/unrealircd/commit/208f4a504b70d9064e46a5959e30c3026a98d11f

Sorry, I forgot to mention the bugid and your name :p

Thanks for the report!

Issue History

Date Modified Username Field Change
2016-01-02 22:33 Zoddo New Issue
2016-01-02 22:34 Zoddo Tag Attached: bug;certfp
2016-01-02 22:35 Zoddo Tag Detached: bug;certfp
2016-01-02 22:35 Zoddo Tag Attached: bug
2016-01-02 22:35 Zoddo Tag Attached: certfp
2016-01-03 10:09 syzop Priority high => normal
2016-01-03 10:11 syzop Tag Detached: bug
2016-01-03 10:12 syzop Assigned To => syzop
2016-01-03 10:12 syzop Status new => acknowledged
2016-01-03 10:13 syzop Note Added: 0019010
2016-01-03 10:13 syzop Status acknowledged => confirmed
2016-01-03 15:40 syzop Note Added: 0019011
2016-01-03 15:40 syzop Status confirmed => resolved
2016-01-03 15:40 syzop Fixed in Version => 4.0.1
2016-01-03 15:40 syzop Resolution open => fixed