View Issue Details

IDProjectCategoryView StatusLast Update
0004556unrealmodule apipublic2016-05-22 16:09
ReporterbonnedavAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1 
Target VersionFixed in Version4.0.4 
Summary0004556: no error sent on /SAMODE nick (setting user modes)
DescriptionI can't get SAMODE to set/unset a user mode. It does not even return anything.
Steps To ReproduceTry to set/unset a user mode with SAMODE.
TagsNo tags attached.
3rd party modules

Relationships

related to 0003691 resolvedsyzop Error code 502 never given 

Activities

syzop

2016-04-03 11:31

administrator   ~0019182

Right, that's indeed not supported. But the error should be improved :)

Could use 0003691 for this

bonnedav

2016-04-03 12:34

reporter   ~0019186

I consider it not being supported to be a bug. Until it is fixed, UnrealRCd will not work for me.

syzop

2016-04-03 13:11

administrator   ~0019188

It's not a bug, nowhere it says you can change modes on other users through SAMODE. The command documentation is as follows:

Allows a Services Administrator to change the mode on a channel,
without having Operator status.
Services Admin Command
-
Syntax: SAMODE <channel> <mode>
Example: SAMODE #Support +m

If you want this new functionality, that would be a feature request. In that case, please explain your use-case in detail to have us consider it for a future version.

syzop

2016-04-09 09:24

administrator   ~0019210

ack'ed as "no error sent" issue

syzop

2016-05-22 16:09

administrator   ~0019267

[unreal40 f2f63c2] Send error message when /SAMODE is used with a non-existent target. Reported by bonnedav (0004556).

Issue History

Date Modified Username Field Change
2016-01-23 03:02 bonnedav New Issue
2016-04-03 11:31 syzop Note Added: 0019182
2016-04-03 11:31 syzop Relationship added related to 0003691
2016-04-03 12:34 bonnedav Note Added: 0019186
2016-04-03 13:11 syzop Note Added: 0019188
2016-04-09 09:24 syzop Note Added: 0019210
2016-04-09 09:24 syzop Severity minor => tweak
2016-04-09 09:24 syzop Status new => acknowledged
2016-04-09 09:24 syzop Summary SAMODE wont set/unset user modes. => no error sent on /SAMODE nick (setting user modes)
2016-05-22 16:09 syzop Note Added: 0019267
2016-05-22 16:09 syzop Status acknowledged => resolved
2016-05-22 16:09 syzop Fixed in Version => 4.0.4
2016-05-22 16:09 syzop Resolution open => fixed
2016-05-22 16:09 syzop Assigned To => syzop
2017-01-06 15:48 syzop Category module => module api