View Issue Details

IDProjectCategoryView StatusLast Update
0004576unrealmodule apipublic2016-03-04 13:32
ReporterOUTsiderAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1 
Target VersionFixed in Version4.0.2 
Summary0004576: SERVER parser error causing uplinks to show bad server description
DescriptionUnreal 4 currently sends SERVER as for 3.2.x series, however, it misses the numeric in the VL string, causing the parser to fail. Also I detected a bug in the parser for SERVER as well. Applies is a patch to fix this.

for example:
U4000-Fhin6OoEM TestServer instead of U4000-Fhin6OoEM-1 TestServer
Steps To ReproduceLink a server and check /links
* trinkhalle.bullet-irc.net tubulev.bullet-irc.net :1 U4000
* solaris.bullet-irc.net tubulev.bullet-irc.net :1 U4000
* tubulev.bullet-irc.net tubulev.bullet-irc.net :0 tubulev, made my day
TagsNo tags attached.
3rd party modules

Activities

OUTsider

2016-02-09 23:17

reporter  

unreal4-serverdescription.diff (2,176 bytes)

syzop

2016-03-04 13:31

administrator   ~0019122

Last edited: 2016-03-04 13:32

View 3 revisions

Thanks for the report and the patch, committed :)

[unreal40 4cad9cb] SERVER parser error causing uplinks to show bad server description, reported by and patch from OUTsider (0004576).

Patch used only with minor changes & unrelated enhancements: one %i should have been %s, some annoying (char *) casts removed which existed in the original code as well, moved 'tmp' variable, collapsed NULL initalization, oh yeah and in the original code it set the description to our own name, I replaced that with "server" since that's odd.

https://github.com/unrealircd/unrealircd/commit/4cad9cb0c51f13fd8e9aeda6c7c2d02f57780174

Issue History

Date Modified Username Field Change
2016-02-09 23:17 OUTsider New Issue
2016-02-09 23:17 OUTsider File Added: unreal4-serverdescription.diff
2016-02-29 20:07 syzop Severity block => minor
2016-03-04 13:31 syzop Note Added: 0019122
2016-03-04 13:31 syzop Status new => resolved
2016-03-04 13:31 syzop Fixed in Version => 4.0.2
2016-03-04 13:31 syzop Resolution open => fixed
2016-03-04 13:31 syzop Assigned To => syzop
2016-03-04 13:32 syzop Note Edited: 0019122 View Revisions
2016-03-04 13:32 syzop Note Edited: 0019122 View Revisions
2017-01-06 15:48 syzop Category module => module api