View Issue Details

IDProjectCategoryView StatusLast Update
0004584unrealircdpublic2016-03-04 13:14
ReporterdboyzAssigned Tosyzop 
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.0.1 
Target VersionFixed in Version4.0.2 
Summary0004584: set::modes-on-join should not check for channel mode 'A' since it has been removed from source
DescriptionTitle says it all, see link below:
https://github.com/unrealircd/unrealircd/blob/unreal40/src/s_conf.c#L7206

Also, channel modes 'f', 'P' and 'Z' should not be allowed to be included in set::modes-on-join.

Probably it would be a good idea to just disallow all channel modes of type 1 and 2 from set::modes-on-join since channel modes can be added by third party modules.
TagsNo tags attached.
3rd party modules

Activities

blank

2016-02-25 19:16

reporter   ~0019100

Don't disallow +f, lots of networks use it.

OUTsider

2016-02-27 11:19

reporter   ~0019101

Last edited: 2016-02-27 11:20

View 2 revisions

Wouldn't it be a better idea to accept the config setting regardless of the setting and check the restriction when modes-on-join actually gets performed ? This should also allow modes added by third party modules to be used.

syzop

2016-03-04 13:14

administrator   ~0019121

[unreal40 6307224] Update set::modes-on-join restrictions to reflect current status (and be a bit more liberal). Reported by dboyz (0004584).

It now restricts +qaohv, +beI, and also +k/+l because I'm lazy. All the rest is permitted.. if a user wants to do silly things......

Issue History

Date Modified Username Field Change
2016-02-24 07:36 dboyz New Issue
2016-02-25 19:16 blank Note Added: 0019100
2016-02-27 11:19 OUTsider Note Added: 0019101
2016-02-27 11:20 OUTsider Note Edited: 0019101 View Revisions
2016-03-04 13:14 syzop Note Added: 0019121
2016-03-04 13:14 syzop Status new => resolved
2016-03-04 13:14 syzop Fixed in Version => 4.0.2
2016-03-04 13:14 syzop Resolution open => fixed
2016-03-04 13:14 syzop Assigned To => syzop