View Issue Details

IDProjectCategoryView StatusLast Update
0004586unrealircdpublic2016-03-04 12:45
ReportercapitaineAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version8.3
Product Version4.0.1 
Target VersionFixed in Version4.0.2 
Summary0004586: Partial quit message
DescriptionWhen a user quits, either the prefix-quit or the comment is missing.
Steps To ReproduceQUIT :testing
ERROR :Closing Link: john[localhost] (testing)

Additional InformationSometimes, the prefix-quit is shown and the comment is missing instead, but I can't reproduce that case.
TagsNo tags attached.
3rd party modules

Activities

syzop

2016-03-04 12:45

administrator   ~0019119

Thanks for the report, fixed now.
[unreal40 da9a1be] set::prefix-quit was not working, reported by capitaine (0004586).

Cause was nenolod's ircsprintf -> ircnsprintf mass replace and while ircsprintf returns a pointer to the end of the string (to make it useful), ircsnprintf returned a pointer to the beginning of the string (more classic).
I've rewritten the code a bit as it was too mysterious (variable naming too).

https://github.com/unrealircd/unrealircd/commit/da9a1be85b56372d2c23ccd8abc283d16c520162

Issue History

Date Modified Username Field Change
2016-02-28 13:48 capitaine New Issue
2016-03-04 12:45 syzop Note Added: 0019119
2016-03-04 12:45 syzop Status new => resolved
2016-03-04 12:45 syzop Fixed in Version => 4.0.2
2016-03-04 12:45 syzop Resolution open => fixed
2016-03-04 12:45 syzop Assigned To => syzop